Learning Objectives

After successfully completing this material, entire classroom training and laboratory exercises, students will learn 3D animation skills in an acceptable manner. The following compiled information will give students a basic level understanding of 3d animation in general with a special focus to industry standard animation application Autodesk Maya. This material covers only theoretical concepts, which will be useful to students as a reference material for their final exams.

Animation Definition

Animation is a type of optical illusion; it is the process by which we see still pictures move. It involves the appearance of motion caused by displaying still images one after another at the rate of 24 pictures per second. The most common method of presenting animation is as a motion picture or video program, although several other forms of presenting animation also exist.

All about 2D & 3D Animation in general

Animation is a field of art or science that has the capability to impart life and zeal to non living characters. Basically it is based on the phenomenon of persistence of vision that allows the visual illusion of the objects. It is a phenomenon of an eye in which an image continues to appear in one’s vision after the exposure to the original image has ceased. This happens for about one twenty-fifth of a second. In early days animation was restricted to only hand drawings. But with the advent of technological knowhow animation has got a
new face that is known as two dimensional and three dimensional animations. A three dimensional animation is far better than two dimensional. It adds more vigor and Vivacity to animation.

Animation is simulation of movement created by a series of pictures or frames. It starts with drawing independent pictures and putting them together in a frame to form the illusion of continuous motion. Two dimension means that the picture is drawn with help of two coordinates of geometry. These are designated as x (horizontal) coordinate and y (vertical) coordinate. 2D is flat which means that if a picture is turned to the side then it becomes a line. Whereas 3D includes an extra dimension known as z coordinate which stands for rotation and depth. The basic difference between 2d and 3d can be illustrated by drawing a rectangle and a cube. Rectangle is a 2D figure whereas cube is a 3D figure. 3D presents the object from every possible direction like in real life. 2D bitmap or vector graphics are used to create 2D animation figures.

What are the fields in which animation is used?

Animation is used for entertainment purposes. In addition to its use for entertainment, animation is considered a form of art. It is often displayed and celebrated in film festivals throughout the world. Also used for educational purposes, animation has a place in learning and instructional applications as well.

What is the difference in animation 2d and 3d?

The most obvious difference between the two genres of animation is of course the three dimensional characteristics or the appearance of depth. While 2D animation is a flat animation and all the actions happen in the x-y axes, 3D animation includes an extra dimension and that is the z axis.

The working method for creating 2d cartoon characters and 3d animated figures are entirely different. While in 2D animation the process of cartoon character creating involves sketching the character from different sides with the help of onion skin tools. Creating a 3d model requires digital modeling and is more similar to sculpting a character than drawing one. An animator working in 3d dimensional environment constantly has to be aware of how his/her changes to the model side view affect the front view or any other view for that matter.

Creating a perfect looking model is a difficult task since all the different views have to be taken into the consideration. Creating a 3d model is often based on a pre-made two dimensional sketches of the character from different views. After the model is created a material has to be assigned to it and the model has to be textured properly.
Although the process of character creating for 3D animation is usually taking more time than 2D character creation, the process of creating the animation itself can be considered easier by many animators. In 2D animation the animation is created by drawing almost every frame of the animated movie. In 3D, the animation is created by changing the poses and the placement of already created 3D models. The created scene can be viewed from different angles and by that it is easier and faster to create an illusion of change in the environment.

**What are the various techniques used in creating 2D and 3D animation?**

Various techniques that are acclimated in creating 2D abstracts are morphing, twining, onion skinning, Anime, and amid rotoscoping. Admitting 3D action involves agenda clay of characters. Various accomplish that are complex in 3D action are appearance sketching, appearance modeling, Anime, arena building, texturing, abating and camera setup, rendering, abating and camera setup, rendering, alteration and bond etc. Other techniques, Anime, which can be activated, are the use of algebraic functions, apish fur or hair and the use of motion capture. In this way we can abstract greater use of multimedia through 2D and 3D animation.

**3D Computer Graphics**

Animation is an art form created and cultivated over the last century. While drawing, painting, sculpting and photography allow artists to represent shape and form at a single point in time, animation lets artists explore a world in motion. Through animation, new worlds can be imagined. This modern art form evokes emotion through the movement of a sequence of drawings, paintings, photographs or rendered images.

The introduction of 3D computer graphics over the last couple of decades has had a big impact on the world of animation. Digital characters and sets can now be built and animated, then presented in different media formats such as film, video and interactive games. Characters and visual effects can even be seamlessly integrated into live-action footage. Autodesk® Maya® is a 3D animation system that lets artists play the roles of director, actor, set designer and cinematographer.

**3D Computer Animation**

The world of 3D computer graphics has grown from experimental short films to full integration into the creative process for many types of media. From flying logos to digital actors, the field of 3D computer graphics has evolved rapidly over the last two decades. The use of 3D graphic tools is now an important part of many television, film and multimedia projects.
What makes 3D such a useful tool is the way it simulates real objects. The way objects appear in perspective, the way a surface bends and twists, or the way a light illuminates a space—all of these complex 3D effects can now be recreated on the computer. The resulting digital images can then be integrated into other media types using familiar compositing and editing techniques.

Autodesk® Maya® is a 3D animation system that addresses the needs of a wide variety of digital content creators. The Maya software tools and techniques have been developed with the artist in mind, while command-based scripting offers ways to build customized tools that suit more integrated production workflows.

**Animated Short Films**

For many years 3D computer graphics were used primarily in animated short films. The experimental nature of these films was a good match for this new computer graphics technology. Smaller teams of artists, or even individual artists, could explore the use of computers to generate animation without the pressures of a larger feature production schedule.

In fact, Chris Landreth’s Bingo, an animated short film, was created while Maya was still in development. Using Maya, Chris and his team were able to tell a compelling story about the influences of our society on the average person.

Short films provide a fertile ground for experimentation that helps drive innovation in the computer graphics industry. It is also a great way for young animators and students to begin using their animation skills as a vehicle for storytelling.

**Broadcast**

There is a good chance that anyone involved in the early years of 3D computer graphics has had to animate a flying logo. This use of 3D offered a new and dynamic way of getting the message across – always important in the world of advertising.

Since then, the use of 3D in broadcast has evolved and more sophisticated artwork is being produced. Flying logos are now integrated into more complete 3D environments where a product is advertised or a corporate message introduced. Character animation is also used more to bring objects to life and help sell the message.

Maya has helped open the door to a more complex use of 3D in the broadcast world. With integrated modeling, animation, characters, visual effects
and rendering, a smaller video production house can now easily add 3D into their existing 2D workflow.

**Feature Films**

The last few years have seen a sharp rise in the use of 3D in feature films. While many films have integrated 3D into existing live-action scenes, Pixar’s Toy Story® became the first feature-length animation that used 3D exclusively for characters and sets. Sony Pictures Imageworks’ Stuart Little® took this one step further and made a digital mouse the star of a live-action movie. Digital creatures, characters and sets continue to show up in the movies and even traditional filmmakers are starting to consider 3D a standard part of the production process.

Feature films tend to use many computer programs to complete a project, including in-house software and off-the-shelf software such as Maya. Maya is most often used for modeling, animation, character animation and dynamics simulations such as cloth. The Maya software open architecture makes it easy for computer graphics (CG) supervisors to build custom tools to help streamline production.

**Interactive Video Games**

Over the years, video games have developed from black and white pixels to real-time virtual environments built with 3D characters and sets. The graphics used in these games have always conformed to the capabilities of the game console on which they are delivered. Next-generation game consoles are continually increasing their computing power to be comparable to the workstations used to run Maya. This is breaking down limitations of the past.

Game artwork is becoming more sophisticated with complex 3D models, texture maps, lighting and even dynamics. Maya is an ideal tool for generating this kind of 3D artwork and includes tools to address the special needs required to build content for real time.

**Visual Effects**

While CG actors star in movies of their own, 3D computer graphics is changing how visual effects are used for both film and television. Smaller productions can now afford to integrate 3D graphics into their work, while large film productions can now achieve effects only dreamed of in the past.

Film sets can be partially built and then extended with detailed 3D digital sets. Also, animated stunt people can be thrown off buildings in ways not recommended for real people. And smoke, fire and exploding objects can now be simulated within the safety of a computer screen.
The Maya software tools, especially Maya dynamics, are ideal for generating visual effects that can be fully integrated into live-action shots. The best effects make it impossible to find the line between reality and where computer graphics are used.

**Visualization and Web**

Digital content creation tools are used in a number of fields including fine arts, architecture, design, education and scientific research. Some of these fields require 3D computer graphics to produce highly realistic images for the evaluation of projects or prototypes. With advances in the web’s ability to present graphic and 3D information, visualization on the internet is emerging as an important tool for many companies.

**TIP**

New or Novice 3D artists should take the time to learn one or more of the following traditional art forms because they can help enhance 3D skills

**Drawing and Sketching**

Drawing is a technique of representing the real world by means of lines and shapes. This skill requires the ability to observe and record the three-dimensional world. This skill can also be used to create storyboards and character sketches great tools for developing an idea before proceeding to computer graphics.

**Cel Animation**

Cel animators create 2D art through motion. Cel animation includes traditional techniques such as squash and stretch, anticipation, overlapping action and follow through. Many of these 2D techniques translate very well into 3D environments.

**Painting**

Painters learn to work with color, light, shape, form and composition. On the computer, these skills help create texture maps, position lights and compose scenes.

**Cinematography**

Knowledge of traditional cinematography will help artists use real world techniques when setting up CG lights and cameras. This skill is very important when working with 3D graphics that are integrated into live-action plates.
Photography

Still photography requires an understanding of lighting and camera effects such as key lights, focal length and depth of field. Photography also teaches good composition techniques that are useful for framing scenes.

Sculpture

Sculpturing with clay, stone and metal requires an intimate understanding of shape and form. Hands-on experience in shaping complex surfaces is a great asset when working with digital surfaces in Maya.

Architecture

Architects often make good 3D artists because they are trained to think in plane, section, elevation and perspective. Building models by hand is another skill they develop that makes it much easier to work in a digital environment.

What are 3d computer graphics

3D computer graphics (in contrast to 2D computer graphics) are graphics that use a three-dimensional representation of geometric data that is stored in the computer for the purposes of performing calculations and rendering 2D images. Such images may be stored for viewing later or displayed in real-time.

3D computer graphics rely on many of the same algorithms as 2D computer vector graphics in the wire-frame model and 2D computer raster graphics in the final rendered display. In computer graphics software, the distinction between 2D and 3D is occasionally blurred; 2D applications may use 3D techniques to achieve effects such as lighting, and 3D may use 2D rendering techniques.

3D computer graphics are often referred to as 3D models. Apart from the rendered graphic, the model is contained within the graphical data file. However, there are differences. A 3D model is the mathematical representation of any three-dimensional object. A model is not technically a graphic until it is displayed. Due to 3D printing, 3D models are not confined to virtual space. A model can be displayed visually as a two-dimensional image through a process called 3D rendering, or used in non-graphical computer simulations and calculations.

1. 3D computer graphics creation falls into three basic phases
2. 3D modeling – the process of forming a computer model of an object’s shape.
3. Layout and animation – the motion and placement of objects within a scene.
4. **3D rendering**: The computer calculations that, based on light placement, surface types, and other qualities, generate the image

1. **Modeling**

   The model describes the process of forming the shape of an object. The two most common sources of 3D models are those that an artist or engineer originates on the computer with some kind of 3D modeling tool, and models scanned into a computer from real-world objects. Models can also be produced procedurally or via physical simulation. Basically, a 3D model is formed from points called vertices (or vertexes) that define the shape and form polygons. A polygon is an area formed from at least three vertexes (a triangle). A four-point polygon is a quad, and a polygon of more than four points is an n-gon[citation needed]. The overall integrity of the model and its suitability to use in animation depend on the structure of the polygons.

2. **Layout and animation**

   Before rendering into an image, objects must be placed (laid out) in a scene. This defines spatial relationships between objects, including location and size. Animation refers to the temporal description of an object, i.e., how it moves and deforms over time. Popular methods include keyframing, inverse kinematics, and motion capture. These techniques are often used in combination. As with modeling, physical simulation also specifies motion.

3. **Rendering**

   Rendering converts a model into an image either by simulating light transport to get photo-realistic images, or by applying some kind of style as in non-photorealistic rendering. The two basic operations in realistic rendering are transport (how much light gets from one place to another) and scattering (how surfaces interact with light). This step is usually performed using 3D computer graphics software or a 3D graphics API. Altering the scene into a suitable form for rendering also involves 3D projection, which displays a three-dimensional image in two dimensions.

**Autodesk Maya**

Autodesk Maya, commonly shortened to Maya, is 3D computer graphics software that runs on Microsoft Windows, Mac OS and Linux, originally developed by Alias Systems Corporation (formerly Alias|Wavefront) and currently owned and developed by Autodesk, Inc. It is used to create interactive 3D applications, including video games, animated film, TV series, or visual effects. The product is named after the Sanskrit word Maya, the Hindu concept of illusion.
Maya is an application used to generate 3D assets for use in film, television, game development and architecture. The software was initially released for the IRIX operating system. However, this support was discontinued in August 2006 after the release of version 6.5. Maya was available in both “Complete” and “Unlimited” editions until August 2008, when it was turned into a single suite.

Users define a virtual workspace (scene) to implement and edit media of a particular project. Scenes can be saved in a variety of formats, the default being .mb (Maya Binary). Maya exposes a node graph architecture. Scene elements are node-based, each node having its own attributes and customization. As a result, the visual representation of a scene is based entirely on a network of interconnecting nodes, depending on each other’s information. For the convenience of viewing these networks, there is a dependency and a directed acyclic graph.

Users who are students, teachers (or veterans or unemployed in USA markets) can download a full educational version from the Autodesk Education community. The version available at the community are without restrictions (once activated with the product license), except for the watermarks on output renders. It comes with a full 36 months license. Once it expires, users can log in to the community to request for a new 36 months license.

Additionally, a perpetual student license can be purchased for Maya. This license does not expire and the student version can be upgraded to the commercial version at a significant discount. It can be used even after the student graduates, the only restriction being non commercial use. No watermarks are created during output, making the student version of Maya suitable for portfolio creation.

However, files saved with this version are recognized by all versions of Maya as files created by a student version.

System requirements

Operating systems

Autodesk supports the Windows (XP SP3 or later), Mac, and Linux platforms. As of Maya 2011, the software is 64-bit under Mac OS X. On Linux, the supported distributions are Red Hat and Fedora, 64-bit. While Autodesk acknowledges that the application is not limited to the aforementioned releases, such as the specific Linux distributions, it does not support them. Autodesk Maya 2012 does not support Mac OS X Version 10.7 and above ("Lion") yet.
Hardware requirements

Autodesk has published system requirements to run Maya at adequate performance. The specifications are identical for both x86 and x64 platforms.

<table>
<thead>
<tr>
<th>Hardware</th>
<th>Spec</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor</td>
<td>Intel Pentium 4 or higher, AMD Athlon 64, AMD Opteron processor, AMD Phenom processor</td>
</tr>
<tr>
<td>Video card</td>
<td>Qualified hardware-accelerated OpenGL graphics cards</td>
</tr>
<tr>
<td>Memory</td>
<td>2 GB, 4 GB for 64-bit OS</td>
</tr>
<tr>
<td>Hard drive</td>
<td>10 GB</td>
</tr>
<tr>
<td>Optical drive</td>
<td>DVD-ROM</td>
</tr>
<tr>
<td>Internet browser</td>
<td>Microsoft Internet Explorer 7.0 or higher, Apple Safari, or Mozilla Firefox, or Google Chrome</td>
</tr>
</tbody>
</table>

Maya History (very brief)

Autodesk Maya 2013 Service Pack 1 (29. Jun 2012-refix-2012-Jul-09) [mray 3.10.1.9]

Autodesk Maya 2013 (27. Mar 2012)

Bullet Physics 2.8.0 (plug-in); Maya nHair; Alembic Caching; New Node Editor; Heat Map Skinning; ATOM Animation Transfer; Live Update Manager; Qt 4.7.1; Python 2.6.4; MentalRay 3.10.1.4

A|W Maya 1.0 (February 1998)

For further information on timeline of Autodesk Maya refer to Wikipedia.

Animation software tools List of 3D animation software

Software packages for preparing three-dimensional animated media include:

- Autodesk 3ds Max
- Autodesk Maya
- Autodesk Softimage
- Anim8or
- Macromedia Flash
- Art of Illusion
- Blender
- Bryce (software)
- Cinema 4D
- DAZ Studio
- Electric Image Animation System
- Houdini
- K-3D
- LightWave 3D
- Make Human
- Modo
- Multigen Creator and VegaPrime
- Nickelodeon 3D Movie Maker
- Poser
- Ammage Redda
- Synfig
- Toon Boom Harmony 9
- Messiah Studio
- Nuke & Nukex
- MMD
- DrawPlus
- Express Animator
- Microsoft Silverlight
- Motion
- Retas
- Sencha Animator
List of 2D animation software

Software packages for production of two-dimensional animation include

**Free and Open-source**

- Ajax Animator
- Chalanam
- KToon
- Open Dialect
- Pencil
- Pivot Stickfigure Animator
- Stykz
- SVGDreams PHP animation library
- SWFTools
- Synfig
- Pencil
- TISFAT
- Vectorian Giotto

**Paid**

- Adobe After Effects
- Adobe Flash Professional
- Anime Studio
- Antics 2-D Animation
- Artoonix
- Cacani
- CrazyTalk Animator
- CelAction2D
- Dimp Animator
- DigiCel FlipBook
• Sencha Architect
• Swish Max
• Toon Boom
• Toufee
• TVPaint
• Toonz

Animation Techniques

Traditional animation
• Full animation
• Limited animation
• Roto scoping
• Live-action/animation

Stop motion
• Puppet animation
• Clay animation
• Cutout animation
• Silhouette animation
• Model animation
• Go motion
• Object animation
• Graphic animation
• Brickfilm
• Pixilation

Computer animation
• 2D animation
• 3D animation
Other animation techniques

- Drawn on film animation
- Paint-on-glass animation
- Erasure animation
- Pin screen animation
- Sand animation
- Flip book

Other techniques and approaches

- Character animation
- Chuckimation
- Multi-sketching
- Special effects animation
- Animatronics
- Stop motion

Importance of drawing in animation context:

Depends on whether you’re doing 2D or 3D Animation. For 2D I definitely think you need to be able to have the drawing skills. If you can’t draw, it hurts you tremendously, while dealing with traditional animation.

2D Animation is being outsourced to other countries for the mainstream so there isn’t very many 2D inbetweener jobs out there (although Pixar did make the announcement that their bringing it back-I have yet to see anything with this). I don’t know what people are thinking when they say you don’t have to have good drawing skills to do 2D animation. Yes you do. And besides that fact you have to be able to get yourself past the door to be able to work at a studio. If you don’t know anyone on the inside it’s harder for you so you have to submit your stuff to be considered. And do you know what they look for? Good drawing skills. It’s a fact.

Now with 3D Animation that’s a little different. If you want to do that then you have to be good at animation acting (arcs, overlapping, follow-through, etc). Basically animating your character very well in the program. But the thing about that is if you go to an animation school at some point you’re going to have to go through reviews and 2D drawing skills are based off that.
Finally, practice makes perfect if you have any type of drawing skills just keep working at it.

**The Process of Animation**

(based on traditional Walt Disney Studios Animation)

1. A storyboard is made, all the animators and directors come together to discuss the entire film.

2. The storyboards are presented as the story.

3. Once the story is laid out, the dialogue is recorded. This is done before animation, so the animators know what the characters will say.

4. After the dialogue is recorded, the animators can make rough sketches of just the characters. Usually these drawings are quite messy; there is still no color, or background. Some animated films have used over 50,000 individual drawings.

   At most animation studios, the best animators only sketched a few animation drawings, leaving gaps in between. Later on, a person called an “inbetweener” would finish the scenes, by drawing in between the areas that the animator had left.

5. Once the entire film has been drawn on paper, the animation drawings go to the inking department. There, the inkers copy the animation drawings on to clear celluloid acetate, sometimes called a Cel.

6. After the outline of the characters has been made, the unfinished Cel’s go to the Painting Department. The painters flip the Cel over, and paint the colors on the back. They paint on the back so the characters appear crisp, and have an outline.

7. Before the Animation Cels get photographed a background must be added. Because a Cel is clear, and it only has the painted character on it, if a background is made, it will show through. Usually backgrounds are painted with Tempera or Water Color paint. Although, in some Disney productions, the background was painted on glass, and combined with other glass painted backgrounds to create the illusion of extreme movement. (This technique is use in Snow White and the Seven Dwarfs.)

8. Now all the combined elements (the Cel and the background) can be photographed. Although, the final product is not filmed with a normal projector, or camera. A special device, with a lens mounted facing down on to a table top captures each frame of the animated feature. Usually, the background is placed
into a special mount, then covered with the Cel, then covered with a large piece of glass, then photographed.

9. After all the drawings have been filmed, the dialogue is added. Sometimes the film is edited at this step.

10. The animated film is released, and the general public may view it.

**History and Principles of Animation**

Animation Heritage Early Devices

- Persistence of vision
- Shadow puppets
- Flipbook
- Thaumatrope (1800s)
- Phenakistiscope (1830)
- Zoetrope (1834)

**Animation Heritage Early Devices**

- Photograph
- Muybridge (1885)
- Film projector (Edison, 1891)

**Early “Traditional” Animation**

- First animation using a camera
- 1896, Georges Melies, moving tables
- 1900, J. Stuart Blackton, added smoke
- First celebrated cartoonist
- Winsor McCay
- Little Nemo (1911)
- Gertie the Dinosaur (1914)

**Early Technical Developments**

- 1910, Bray and Hurd
- Patented translucent cels (formerly celluloid was used, but acetate is used now) used in layers for compositing
• Patented gray-scale drawings (cool!)
• Patented using pegs for registration (alignment) of overlays
• Patented the use of large background drawings and panning camera

**Disney**

• Advanced animation more than anyone else
• First to have sound in 1928, Steamboat Willie
• First to use storyboards
• First to attempt realism
• Invented multiplane camera
• Creating illusion of depth
• Zooming
• Parallax
• Motion blur

**Brief History of Computer Animation**

• 1963 – Ivan Sutherland’s (MIT) Sketchpad
• 1970 – Evans and Sutherland (Utah) start computer graphics program (and a Company)
• 1972 – Ed Catmull’s (Utah) animated hand and face (later co-founded Pixar)
• 1970’s – Norm Badler (Penn) Center for Modeling and Simulation, Jack
• 1970’s – New York Institute of Technology (NYIT) Alvy Ray Smith (Cofounded Pixar and Lucas film) and Catmull developed Bbop
• 3D key-frame articulated animation system
• 1980’s – Daniel and Nadia Magnenat-Thalmann (Swiss Universities) become European powerhouses
• 1977 – Starwars
• 1980’s – SGI founded, and Alias/Wavefront founded
• 1982 – Tron (first extensive use of graphical obj.)
1982 – Early use of particle systems (Star Trek II: The Wrath of Khan)
1986 – Young Sherlock Homes (first use of synthetic character in film)
1986 – First digital wire removal, Howard the Duck
1988 – First digital blue screen extraction Willow

“There is no particular mystery in animation... it’s really very simple, and like anything that is simple, it is about the hardest thing in the world to do. “Bill Tytla at the Walt Disney Studio, June 28, 1937.

Principles of Animation

Thomas & Johnson, “The illusion of life: Disney Animation”
John Lasseter, “Principles of Traditional Animation Applied to 3D Computer Animation”, SIGGRAPH’87

- Squash and Stretch
- Anticipation
- Staging
- Pose to Pose
- Follow Through
- Slow in and Slow out
- Arcs
- Secondary Action
- Timing
- Exaggeration
- Solid Drawing
- Appeal

Squash and Stretch: Bouncing Ball animation - Popular exercise

Anticipation and Staging

- Don’t surprise the audience
• Direct their attention to what’s important Follow Through & Overlapping

• The termination of an action and establishing its relationship to the next action

• Audience likes to see resolution of action

• Discontinuities are unsettling

**Slow in Slow out**

• Which motion looks more natural/interesting?

• 2nd and 3rd order continuity increases realness

**Secondary Motion**

• An action that directly results from the primary action

• Increase realness/interest of a scene

• Should not detract the primary motion

**True Computer Animation**

• Generate the image by rendering a 3D model

• Vary the parameters to produce the animation

• Brute force

• Manually set the parameters for every frame

• Still labor-intensive

• Computer key framing

• Lead animators create the important frames with 3D computer models

• Computer draws the in-between

• Used widely in animation production

**Digital Production Pipeline**

• Story

• Storyboards

• Visual development

• Character design
Summary

Animation is the rapid display of a sequence of images to create an illusion of movement. The most common method of presenting animation is as a motion picture or video program, although there are other methods. This type of presentation is usually accomplished with a camera and a projector or a computer viewing screen which can rapidly cycle through images in a sequence. Animation can be made with either hand rendered art, computer generated imagery, or three-dimensional objects, e.g., puppets or clay figures, or a combination of techniques.

The position of each object in any particular image relates to the position of that object in the previous and following images so that the objects each appear to fluidly move independently of one another. The viewing device displays these images in rapid succession, usually 24, 25, or 30 frames per second.

In this session you have learned what is animation, difference between 2d and 3d animation is, history of animation in general, tool and techniques involved in, various principles that influences and extends the quality and productivity of animation etc.

Short Answer Type Questions

1. Write about Winsor McCay.
2. Animation is illusion of movement. Elucidate.
3. Expand FPS.
4. Write about applications areas of animation (where it can be used)
5. List important 2d / 3d Animation software applications (three under each category)
Long Answer Type Questions

1. What is Animation?
2. Write about 2d classical and 3d computer animation.
3. What are the principles of animation?
4. List important stages in digital production.
5. List important events in history of computer animation.
Learning Objectives

In this unit the student will learn the basics of 3D computer graphics using Autodesk Maya. Lectures will cover the application of Maya in the film, television and game industries.

Welcome to Autodesk® Maya®, one of the world’s leading software applications for 3D digital animation and visual effects. Maya provides a comprehensive suite of tools for your 3D content creation work ranging from modeling, animation, and dynamics through to painting and rendering to name but a few.

With Maya, you can create and edit 3D models in a variety of modeling formats and animate your models using Maya’s suite of animation tools. Maya also provides a range of tools to allow you to render your animated 3D scenes to achieve photo realistic imagery and animated visual effects.

You can create convincing visual simulations using Maya dynamics and nDynamics tools. Using Maya® Fluid Effects™, you can simulate and render viscous fluids, atmospheric, pyrotechnic, and ocean effects. Maya® nCloth™ lets you create simulations of fabric and clothing, while Maya® nParticles™ can be used to simulate a wide range of effects including liquids, clouds, smoke, spray, and dust. Other Maya dynamic simulation tools include Maya® Fur™, Maya® Hair™, and Maya® Artisan™ brush tools.

The Maya software interface is fully customizable for those users who require the ability to maximize their productivity. Maya allows users to extend
their functionality within Maya by providing access to MEL™ (Maya Embedded Language). With MEL, you can customize the user interface and write scripts and macros. In addition, a full Application Programmers Interface (API) is available to enhance the power and functionality of Maya. Maya also provides a Python-based Maya API for those users wishing to use it.

The content creation power of Maya is provided to users in an integrated software application that is designed to enhance user productivity and ease of use.

**Fig 2.1 Maya user interface overview**
Introduction

Critical to learning any software application is some initial understanding of the basic concepts: how that software’s world works and the fundamental skills you need to work in that world. If you have never used a three dimensional (3D) software application before, you may initially find Maya different compared to 2D applications.

If you are wondering “where do I begin?”, this chapter is the best place to start. We recommend that you complete the lessons in this chapter so the essential concepts and skills presented become familiar to you.

This chapter covers some of the fundamental concepts and skills for Maya in four lessons

- Topic 1 The Maya user interface
- Topic 2 Creating, manipulating, and viewing objects
- Topic 3 Viewing the Maya 3D scene
- Topic 4 Components and attributes

**Topic 1 The Maya user interface**

Just as the driver of an automobile is familiar with the dashboard of their vehicle, it is important for you to become familiar with the Maya “dashboard.”

The Maya user interface refers to everything that the Maya user sees and operates within Maya. The menus, icons, scene views, windows, and panels comprise the user interface.
Through the Maya user interface you access the features and operate the tools and editors that allow you to create, animate, and render your three dimensional objects, scenes, and effects within Maya.

As you spend time learning and working with Maya, your knowledge of and familiarity with the user interface will increase until it becomes second nature.

In this lesson you learn how to

- Start Maya on your computer.
- Use the Maya interface so that you can begin to understand where and how to access the critical tools to get started with Maya.
- Select the menu and icon sets within Maya.
- Learn the names of tools related to the icons in Maya.
- Create a new scene view.

This first lesson contains additional explanations of the tools and concepts compared to many of the lessons later in this manual. We suggest you take some time to review these explanations as they lay the foundation for understanding where things are in Maya.

Starting Maya

To start Maya on Windows

1. Do one of the following:
   - Double-click the Maya icon on your desktop.
   - From the Windows Start menu, select All Programs > Autodesk > Autodesk Maya 2012 > Maya 2012.

To start Maya on Mac OS X

1. Do one of the following:
   - Double-click the Maya icon on your desktop.
   - Click the Maya icon in the Dock.
   - From the Apple Finder menu, select Go > Applications and then browse for the Maya icon and double-click it to start Maya.

To start Maya on Linux

1. Do one of the following:
• Double-click the Maya icon on your desktop.
• In a shell window, type: maya.

The Maya interface

Now that Maya is running, you first need to understand what you are seeing. There are a lot of items displayed in the Maya user interface.

The best way to begin is to learn the fundamental tools and then learn additional tools as you need them. Begin by learning some of the main tools.

Fig 2.3 Maya interface
The Maya workspace

The Maya workspace is where you conduct most of your work within Maya. The workspace is the central window where your objects and most editor panels appear.

When you start Maya for the first time, the workspace displays by default in a perspective window, or panel. There are the other components of the default perspective view panel:

- The panel is labeled persp at the bottom to indicate that you are viewing the Maya scene from a perspective camera view.
- The panel has its own menu bar at the top left corner of the panel. These menus allow you to access tools and functions related to that specific panel.
The grid is displayed with two heavy lines intersecting at the center of the Maya scene. This central location is called the origin. The origin is the center of Maya’s 3D world, and with all object’s directional values measured from this location.

In Maya, like many other 3D applications, the three dimensions are labeled as the X, Y, and Z axes. The origin is located at X, Y, Z position of 0, 0, 0. The grid also lies along the X, Z plane. We refer to this as a plane because you might visualize an imaginary, flat, two-dimensional square laying along this 3D position.

Maya labels the X, Y, and Z axes with a color scheme: red for X, green for Y, and blue for Z. Many tools that you use in Maya use this color scheme to indicate that you are accessing a particular item that relates to X, Y, and Z in some way.
The axis indicator shows in which direction, X, Y, or Z, you are viewing the Maya scene. The axis indicator is color coded in the red, green, and blue color scheme and appears in the lower left corner of a view panel.

This is extremely useful if you are new to 3D, as many of the instructions in this manual and the Maya Help assume you know where you are viewing the scene in relation to the X, Y, Z axes.

**Main Menu bar**

Tools and items are accessible from pull down menus located at the top of the user interface. In Maya, menus are grouped into menu sets. These menu sets are accessible from the Main Menu bar.

The Main Menu bar appears at the top of the Maya interface directly below the Maya title bar and displays the chosen menu set. Each menu set corresponds to a module within Maya: Animation, Polygons, Surfaces, Rendering, and Dynamics. Modules are a method for grouping related features and tools.

![Menu selector](image)

You switch between menu sets by choosing the appropriate module from the menu selector on the Status Line (located directly below the File and Edit menus). As you switch between menu sets, the right-hand portion of the menus change, but the left-hand portion remains the same; the left-hand menus are common menus to all menu sets. The left-hand menus contain File, Edit, Modify, Create, Display, and Window.
To select a specific menu set

1. On the Status line, select Animation from the drop-down menu.

   The Main Menu changes to display the menu set that relates to the Animation module. In particular, menu titles such as Animate, Deform, Skeleton, Skin, and so on, appear.

2. Using the menu selector, choose Polygons from the drop-down menu.

   The main menu changes to display the menu set for Polygons. Menu titles such as Select, Mesh, Edit Mesh, and so on, appear.

   For now, leave the menu set at Polygons. You will use this set in the next step.

To create a primitive 3D object from the Polygons menu set

1. Select Create > Polygon Primitives > Interactive Creation and ensure that a check mark does not appear beside this item.

   For this lesson, you won’t use this option.

2. From the Main Menu Bar, select Create > Polygon Primitives > Cube.

   Maya creates a 3D cube primitive object and places it at the center (origin) of the Maya workspace.
Status Line

The Status Line, located directly below the Main Menu bar, contains a variety of items, most of which are used while modeling or working with objects within Maya. Many of the Status Line items are represented by a graphical icon. The icons save space in the Maya interface and allow for quick access to tools used most often.

In this lesson, you learn about some of the Status Line areas.

You’ve already learned the first item on the Status line: the Menu Selector used to select between menu sets.

The second group of circled icons relate to the scene and are used to create, open, and save your Maya scenes.
The third and fourth group of buttons are used to control how you can select objects and components of objects. You will learn more about selection of objects in later lessons.

The fifth group of icons are used to control the Snap Mode for objects and components. You will begin to use these tools in a later lesson in this chapter.

The last section comprise three buttons that are used to show or hide editors, including the Attribute Editor, Channel Box, Layer Editor, and Tool Settings. The default display shows the Channel Box and the Layer Editor. When you create an object, like the cube for example, information about that object displays in these editors. You will learn how to use these editors later in this chapter.

For better organization on the Status Line, all of the icon buttons are broken into groups that you can expand and collapse, as shown.

The Shelf is located directly below the Status line. The Maya Shelf is useful for storing tools and items that you use frequently or have customized for your own use. You can keep the tools and items you use most frequently in a location that provides handy access. Maya has some of the Shelf items pre-configured for your use.
To create an object using a tool from the Shelf

1. From the Shelf, select the Surfaces tab in order to view the tools located on that shelf.

2. Select Create > NURBS Primitives > Interactive Creation to ensure that a check mark does not appear beside the item.

   For this lesson, you won’t use this option

3. From the Shelf, select the NURBS sphere icon located at the left end by clicking on it.

   Maya creates a sphere primitive object and places it at the center of the Maya workspace in the same position as the cube.

   **Tip**

   You can determine if this is the correct tool prior to choosing it by first placing your mouse cursor over the icon, the name or description of it appears in a popup window directly over it.
In your scene view the wireframe outline of the cube you created earlier in the lesson has changed color to navy blue, and the sphere is displayed in a bright green color. The sphere is now the selected object and the cube is no longer selected. In Maya, when the object displays like this, we refer to it as being selected or active.

Selection of objects and components is a way of indicating to Maya that this particular item is to be affected by the tool or action you will subsequently choose. As you work with Maya, you will be selecting and deselecting items a lot. You will learn how to select and deselect objects later in this chapter.

Some numerical information appears in the Channel Box editor on the right hand side of the user interface. This information relates to X, Y, and Z, translation, rotation, and scaling for the active object. The X, Y, and Z Translate numerical values are currently set to 0. This indicates that the sphere’s location is at the origin. The Channel Box is useful for viewing and editing this type of basic information. You will use the Channel Box later in this chapter.
To hide or show the Channel Box

1. To hide the Channel Box, click the Show/Hide Channel Box icon from the right end of the Status line.

   The Channel Box disappears, and the perspective scene view expands slightly. With the Channel Box hidden, you have more working area in your scene view.

2. To show the Channel Box, click the Show/Hide Channel Box icon on the Status line. The Channel Box appears in the scene view.
Saving your work

Make it a habit to save your work often when working on your Maya projects. In that way, you can always open an earlier version of your work should you make a mistake.

Maya refers to everything you’ve created in your workspace as the scene. This includes any objects, lights, cameras and materials associated with your working session.

To save your Maya scene

1. Select File > Save Scene.

   A file browser appears, listing the Getting Started Maya 2012 Lesson Data\Basics\scenes folder where you can save your scene.

   If the Getting Started Maya 2012 Lesson Data\Basics directory does not appear, you need to create the Basics folder and set it as your Maya project.

Type : Lesson1 in the file name text box.

2. Click Save.

   Maya saves your file to the scenes directory within your GettingStartedMaya2012LessonData\Basics project directory. Maya automatically saves the file with a .mb file extension. The .mb file extension indicates that the scene was saved as a Maya binary file: the default file type for a Maya scene.

Exiting Maya

Before you exit Maya, ensure you save any work that you want to retrieve and continue with at a later time.

To exit Maya

1. Select File > Exit from the main menu.

   Maya does one of the two following actions:

   • If you have saved your scene immediately preceding the Exit command, Maya exits.
   
   • If you have not recently saved your scene, a message prompt appears on the screen asking if you want to save your changes. Click either Save, Don’t Save, or Cancel.
In this lesson you began your orientation to Maya by learning

- How to start Maya on your computer.
- The Maya workspace, and how it shows three dimensional space (X, Y, Z).
- How Maya color-codes items and tools related to X, Y, Z.
- The location of the main menus for the various modules within Maya.
- How to create a three-dimensional object from the Polygons menu.
- The location of the Status Line and how items are displayed as icons.
- About the Shelf how to create a three dimensional object from the Shelf.
- How to hide and show the Channel Box and that basic transformation, scaling, and rotational information for an object can viewed in the Channel Box.
- How to save your work.
- How to exit Maya.

As you proceed through Getting Started with Maya you should be familiar with the fundamental concepts and skills covered in this first chapter.

If you want to learn more about a particular tool or feature that has been presented in this lesson, refer to the Maya Help.

**Creating, Manipulating, and Viewing Objects**

Using primitive objects to model 3D forms is a great place to continue learning about Maya. You can create many types of 3D objects using Maya and then move, scale, and rotate them to create more complex forms in your scene.

In this lesson, you begin to construct a classic temple using the primitive object creation tools in Maya. The project is not very complex and provides you with experience in using some of the important object manipulation and viewing tools.
As you continue to work with Maya, you’ll learn how to visualize more complex forms using these basic objects. Maya has many advanced tools and options for modeling complex forms, as you will learn in later chapters.

In this lesson, you learn how to

- Create 3D primitive objects.
- Select objects for manipulation and editing purposes.
- Move and rotate objects using your mouse.
- Move, rotate, and scale objects using numeric input.
- Duplicate objects.
- Change the viewing panels in Maya using a variety of methods so you can view your objects from different points of view.
- Undo actions when you need to undo a particular task or step.

Creating a new scene

You begin your temple project by creating a new empty scene.
To create a new scene

1. Start Maya (if it is not already running).
   
   When Maya starts, it automatically creates a new scene.
   
   If Maya was previously running, follow steps 2 and 3.

2. From the main menu, select File > New Scene.
   
   Maya displays the following prompt.

   ![Warning scene not saved]

   Fig 2.20 Warning scene not saved

3. Click no.
   
   Maya creates a new scene and delete everything that was in the previous scene.

**Primitive objects**

   Maya provides many types of primitive types and shapes such cubes, spheres, cylinders, and planes.

   ![Primitive objects]

   Fig 2.21 Primitive objects

   Primitive objects can be used as a starting point for a wide variety of shapes and forms. The most common workflow when using primitive objects is:
• Set the construction options for the primitive when you initially create it so that it appears in the Maya scene roughly in the size and shape that you require.

• Move, scale, and rotate the primitive object into its final position either by direct manipulation (the move, scale, and rotate tools), or by entering numeric values through an editor.

• Duplicate the primitive objects to create multiple copies of the original or create different variations from your original primitive object.

In this section, you construct the base for the temple using a polygonal cylinder primitive. The octagonal shape is created by modifying the creation options for the cylinder tool before you create the object. If you did not modify the cylinder options you would create a round cylinder.

**To create a polygonal cylinder for the base**

1. Select the Polygons menu set.

   Note Unless otherwise indicated, the directions in this lesson for making menu selections assume you’ve already selected the Polygons menu set.

   You should also ensure that the Interactive Creation option for primitives is first turned off by selecting Create > Polygon Primitives > Interactive Creation to ensure the check mark does not appear beside the item.

2. From the main menu, select Create > Polygon Primitives > Cylinder >.

   **An option window appears.**

3. In the Polygon Cylinder Options window, select Edit > Reset Settings and then set the following options:

   • Radius : 10
   • Height : 1
   • Axis divisions : 8
   • Height divisions : 1
   • Cap divisions : 1
• Axis: Y

4. In the Polygon Cylinder Options window, click Create.

Maya creates a cylinder primitive object that is octagonal in shape and positioned at the center of the Maya workspace. This cylinder is 20 units wide by one unit high, and has eight faceted sides.

![Fig 2.22](image)

**Note**

You were instructed to reset the option settings as a precaution in case they had been set differently. This is a good habit to practice when working with tool options to avoid getting a result that was different from what you expected.

**The Toolbox: Layout shortcuts**

The Toolbox is located on the left hand side of the Maya user interface. It contains icons that open tools for transforming your objects within Maya (selection, move, rotate, scale) as well as layout shortcuts for changing the views and panel layouts.

The Quick Layout buttons shortcuts allow you to select a different panel or switch to another layout.
You need to finish positioning the cylinder. To do this you need to see the object from a side view to make sure it is sitting exactly on the ground plane.

**To change the panel layout to view the base from a side view**

1. From the Toolbox, click the Four View layout shortcut.

The workspace changes to a four-view layout. The perspective view is located in the top right corner and the other views show the object from the top, front and side. The layout shortcuts have other options that you will learn later in this tutorial.
It’s now possible to see the base from the side view, but it would be easier to determine the position of the base if the side view were enlarged to a full view.

1. To enlarge the side view, position the mouse cursor in the side view, and tap the spacebar of your keyboard.

The workspace changes to a single view layout with the side view in an enlarged view. It is easier to view the position of the base from this side view. Notice that the base lies slightly above and below the ground plane (X, Z).

**Tip**

You can position your mouse cursor in any scene view and tap the spacebar once to toggle the view. If the view is a full panel view, it will change to a four panel view and vice versa.

**The Toolbox: Transformation tools**

You need to move the base slightly upwards in the Y direction so it is positioned on the X, Z plane. To do this you use the Move transformation tool located in the Toolbox.

The upper half of the Toolbox contains the tools for transforming objects (selection, move, rotate, scale) within Maya. When you move your mouse cursor over any transformation tool icon you see the name of the tool appear next to the mouse cursor.

---

*Fig 2.25 Transformation tools*
The tool’s name also appears in the Help Line at the bottom of the Maya window. The Help Line has an additional purpose: it displays summary instructions as you use tools that require several steps.

![Move Tool](image)

**Fig 2.26 Move tool**

**Selection and de-selection of objects**

Before you can transform an object, you must ensure it is selected. You can select objects by clicking them directly, or by dragging a rectangular bounding box around some portion of the object to indicate what you want selected. To deselect an object, you simply click somewhere off of the selected object.

![Selection and de-selection of objects](image)

**Fig 2.27 Selection and de-selection of objects**

To select the base primitive object in the scene view

1. Do one of the following:
   - With your left mouse button, click the object’s wireframe outline in the scene view.
   - With your left mouse button, drag a bounding box around one corner or edge of the object’s wireframe.

   The object is selected when its wireframe outline color displays in a bright green color. If it is not selected, its display color is navy blue.

   To use the Move Tool to adjust the position of the base
1. Select the Move Tool from the Toolbox.

A move manipulator icon appears over the primitive cylinder in the scene view.

The Move Tool Manipulator has handles that point in the direction of the three fundamental axis directions of 3D space: X, Y, Z. The handles are colored red, green, and blue based on their function related to the X, Y, Z axes and control the direction of the movement along an axis.

When you click a specific handle, it indicates that the move is constrained to that particular axis direction.

2. In the side view, drag the green Y manipulator handle to move the primitive cylinder upwards in the Y direction. Move it upwards enough so that the bottom of the base cylinder is aligned with the X axis (the thick dark line of the grid)

![Fig 2.28](image)

The base cylinder now needs to be rotated slightly so the front of the base is parallel to a grid line. Since each facet of the octagon represents 45 degrees of a circle, you need to rotate the object approximately half of that amount or 22.5 degrees.

**To use the Rotate Tool to adjust the position of the base**

1. Display all four views by positioning the mouse cursor in the view and tapping the spacebar of your keyboard.

   The four view panel appears.

2. Position the mouse cursor in the top view and tap the spacebar once.

   The top view appears in the workspace.
3. With the base cylinder selected, choose the Rotate tool from the Toolbox.

A rotate manipulator icon appears over the primitive cylinder in the scene view.

The Rotate Tool manipulator consists of three rings (handles), plus a virtual sphere enclosed by the rings. The colors of the handles correspond to the X, Y, and Z axes. The handles are colored red, green, and blue based on their function related to the X, Y, Z axes and control the direction of the rotation around an axis.

4. In the top view, drag the green Y manipulator ring to rotate the primitive cylinder so that one of the facets of the base cylinder is aligned with the grid as shown in the image below.

You are rotating the cylinder around its Y axis.
You may be asking yourself the question “How do I know if I’ve rotated the base exactly 22.5 degrees?” You can check the accuracy of the rotation by viewing the Channel Box. Rotate Y should be close to 22.5 degrees.

Tip You can undo and redo the last action you performed. Undo reverses the last action you performed on a selected object. It also reverses any action you performed from the Edit Menu.

To undo an action select, Edit > Undo. Maya allows you to perform multiple undos.

The Channel Box

The Channel Box is an editing panel that provides you access to an object’s transformation information and much more. It provides information on three distinct areas for any type of object: The transform node, shape node, and input node.

Nodes are where information about object types are kept track of within Maya. Nodes are comprised of attributes. Attributes refer to information related to what the node is designed to accomplish. In this case, information about the primitive cylinder’s Y axis rotation is referred to as the Rotate Y attribute. You will learn more about nodes later in this tutorial.

When you moved and rotated the cylinder primitive using the Move Tool, you were doing this by your own visual judgement. This will usually be sufficient for many of your creative applications.

If you need to control the attribute of an object with more accuracy you can do this by entering the precise values into the appropriate attribute field of the Channel Box.

To move and rotate the base using the Channel Box

1. With the base cylinder selected, view the Transformation attributes in the Channel Box. Specifically, view the values for Translate Y, and Rotate Y.
2. In the Channel Box, adjust the attribute values so they match the above image by clicking in the field and entering the correct numerical values.

This accurately positions the base in your Maya scene.

Maya named the cylinder primitive when it was first created. Rename the cylinder to something more meaningful to your project.

To rename the cylinder primitive using the Channel Box

1. In the Channel Box, click in the field with the name pCylinder1.

2. Rename the primitive object by typing the new name: templeBase and then pressing Enter.

Duplicating an existing object is a useful way to make an exact copy of it without having to start over. When you duplicate an item the copy takes on the characteristics of the original. Using the Duplicate Tool you can additionally apply transformations to the copy (move, rotate, scale).
Fig 2.32 Duplicating objects

Return to a four view layout to view what you’ve accomplished to this point.

To change the panel layout to a four view layout

1. From the Toolbox, click the Four View layout shortcut.

   The workspace changes to a four view layout. It is easier to view the work from this four view layout.

   The base for the temple is constructed of two levels and appears stepped. You duplicate and scale the templeBase object using the duplicate tool.

To duplicate the temple base

1. Display all four views by positioning the mouse cursor in the view and tapping the spacebar. Then click in the perspective view to display the base in this view.

2. With templeBase selected, choose Edit > Duplicate Special > from the main menu.

   The Duplicate Special Options window appears.
3. In the Duplicate Special Options window, select Edit > Reset Settings and then set the following options.

- Translate : 0 1.0 0
- Rotate : 0 0 0
- Scale : 0.9 1.0 0.9
- Geometry Type : Copy
- Group under : Parent

4. In the Duplicate Special Options window, click Duplicate Special.

Maya creates a duplicate of the templeBase object that is scaled to 0.9 of the original in the X, Z axes, and is one unit above templeBase. As a result of the scale operation, the base for the temple now appears stepped.

Maya keeps track of the name of the duplicated object based on the name of original and renames the duplicated object templeBase1.

In the last lesson we recommended that you save your work at regular intervals. An example of this is when you have just completed a major task such as constructing the base for the temple. With this strategy, if you ever make a mistake, you can always open the previously saved version of your work and begin from there.

To save your Maya scene
1. Select File > Save Scene.

A file browser appears showing the Getting Started Maya 2012 Lesson Data \ Basics \ scenes directory where you can save your scene. Ensure that you are saving in the scenes sub-directory.

If the GettingStartedMaya2012LessonData\Basics directory does not appear, you need to create the Basics folder and set it as your Maya project. See Downloading the lesson files and setting the Maya project.

2. Type Lesson2Base in the file name text box.

3. Click Save.

In this Topic you continued with the fundamental tools and skills to successfully learn

• An overall workflow for constructing forms using primitive objects.
• Where the primitive object tools are located in the main menu.
• How to create a primitive object as well as reset and edit its creation options.
• How to change between a single view and four view panel layout using layout shortcuts and by tapping the spacebar of your keyboard.
• How to select objects by clicking them with your mouse.
• How to move and rotate objects using the transformation tools in the Toolbox.
• That tool manipulators can constrain a transformation to the X, Y, or Z axes.
• How to edit an object’s transformation node attributes (move, rotate, scale) accurately using the Channel Box.
• How to rename objects using the Channel Box.
• How to duplicate objects and apply transformations while doing so.

We suggest you additionally practice the following tasks on your own

• Creating other primitive object types, with various options so that you can understand the variations that are possible.
• Try using the ViewCube™ located in the upper-right corner of the active scene view to change the camera’s viewing angle in relation to the objects in the scene.
• Practice moving, rotating, and scaling objects, and changing between the various scene views (single perspective, four view, single side, single top etc.)

Viewing the Maya 3D Scene

It is important for you to learn how to change your views in a more interactive manner so that you can: view your objects close up or far away, select objects more accurately, or view objects from different angles in your perspective view.

In the previous lesson you learned how to view your 3D scene by changing between single and four view layouts. It is important for you to learn how to change your views in a more interactive manner so that you can: view your objects close up or far away, select objects more accurately, or view objects from different angles in your perspective view.

In this lesson you learn how to

• Understand the difference between moving objects in the scene and moving the point of view on the scene.
• Use the dolly, track, and tumble camera tools to change the view of your scene in both the orthographic and perspective views.
• Rotate objects using the transformation tools in the Toolbox.
• Select objects using a variety of techniques.
• Group objects together so they can be transformed as a unit.
• Display objects in both wireframe and shaded modes.
• Use additional primitive objects and options.

**Camera tools**

In the lessons so far, when you looked at an object from the top, front, or side views you have been viewing the scene through an orthographic view. Orthographic views appear two-dimensional because the object is displayed using parallel projections of only two axes at a time. (Scooter images courtesy of The Art of Maya)

![Front orthographic view](image1)

![Side orthographic view](image2)

**Fig 2.35**

When you view the scene through the perspective view, you are viewing the scene in a three-dimensional manner. The perspective view simulates what your scene would look like from a camera’s point of view.

![Perspective view](image3)

**Fig 2.36**
In Maya, you view the scene through a set of virtual cameras. These cameras are either orthographic or perspective in nature. You can adjust how these cameras view the scene using the Camera Tools.

The three primary methods for manipulating the camera view are dolly, tumble, and track.

**Dolly Tool**

The Dolly Tool gets its name from filmmaking where a camera, mounted on a wheeled tripod, is moved towards or away from the scene. In Maya, dollying allows you to view the items in your scene either close up or from further back.

**To dolly the perspective view**

1. Enlarge the scene view to a single perspective view.
2. Do one of the following:
   - (Windows & Linux) Press the Alt key and drag the mouse to the right while holding down the right button on your mouse.
   - (Mac OS X) Press the Option key and drag the mouse to the right while holding down the right button on your mouse.
3. To dolly the camera outwards from the subject in the scene you can perform the same key and mouse combinations as described above but drag the mouse to the left.

Dolly works in both the perspective and orthographic views.

Tip: If you make an error when adjusting your camera view of the scene, you can reset the camera to its default home setting.
To reset the camera view for a particular orthographic or perspective view:

From the panel menu, select View > Default Home.

![Fig 2.38 Dollying view](image)

**Tumble Tool**

The Tumble Tool allows you to tumble or rotate the camera’s view around a particular center of interest to achieve either a higher or lower vantage point, or a different side angle.

![Fig 2.39 Tumble tool](image)

**To tumble the perspective view**

1. Press the Alt key (Windows & Linux) or the Option key (Mac OS X) and drag the mouse either left or right, or up or down, while holding down the left button on your mouse.
Tumbling the view revolves the camera around the center of the scene view, in whichever direction you drag (left, right, up or down). The Tumble Tool does not work in the orthographic views.

![Fig 2.40 Tumbling the perspective view](image)

**Track Tool**

The Track Tool allows you to move the camera up, down, or sideways in relation to the scene.

![Fig 2.41 Track tool](image)

**To track the perspective view**

1. Press the Alt key (Windows & Linux) or the Option key (Mac OS X) and drag the mouse in any direction, while holding down the middle button on your mouse.

   The Track Tool works for both orthographic and perspective views.
Note

Even though the objects appear to move across the screen when operating any of these camera tools, it is the viewing camera that is actually moved in relation to the scene, not the objects.

Workflow overview

The columns are made up of multiple primitives that are moved, scaled, and rotated into position. Once the first column is created, with each component named and accurately positioned, you will group and duplicate it to create others.
To create a polygonal cube for the pedestal

1. From the Main Menu, select Create > Polygon Primitives > Cube >.

2. In the Polygon Cube Options window, select Edit > Reset Settings and then set the following options:
   - Width : 1.75
   - Height : 0.6
   - Depth : 1.75

   Leave the other options at their default settings.

Note

If the Polygon Cube Options window does not appear, ensure that the Interactive Creation option for primitives is turned off by first selecting Create > Polygon Primitives > Interactive Creation so that a check mark does not appear beside this menu item.

3. In the Polygon Cube Options window, click Create.

   Maya creates a cube primitive and positions it at the origin.

4. In the side view, move the cube upwards (Y axis) so it rests on the top surface of the temple base.

   You can do this using the Move Tool or with the Channel Box. If you use the Channel Box, enter a Translate Y value of 2.3.

   You may find it useful to dolly or tumble the scene view to obtain a better viewpoint.

Fig 2.44
5. In the Channel Box, rename the cube columnPedestal.

**To create a polygonal cylinder for the shaft**

1. From the main menu, select Create > Polygon Primitives > Cylinder.

2. In the Polygon Cylinder Options window, select Edit > Reset Settings and then set the following options:
   - Radius : 0.5
   - Height : 6
   - Axis divisions : 12

   Leave the other options at their default settings

3. In the Polygon Cylinder Options window, click Create.

   Maya creates the cylinder primitive at the origin.

4. In side view, move the cylinder upwards (Y axis) so it rests on the top surface of columnPedestal.

   You can do this using the Move Tool or with the Channel Box. If you use the Channel Box, enter a Translate Y value of 5.6.

5. In the Channel Box, rename the cylinder columnShaft.

The capital for the column rests on top of the column and is very similar to the pedestal. You duplicate the pedestal and position the duplicate at the top of the column.
To duplicate the pedestal to create the capital

1. With only columnPedestal selected, select Edit > Duplicate Special > from the main menu.

   The Duplicate Special Options window appears.

2. In the Duplicate Special Options window, select Edit > Reset Settings and then set the following options:
   • Translate : 0 6.6 0
   • Scale : 0.8 1.0 0.8

   Leave the other options at their default settings.

3. In the Duplicate Special Options window, click Duplicate Special.

   Maya creates a duplicate of the columnPedestal object and moves and scales it based on the options you set.

   Note

   If you positioned the geometry for the column using the Transform Tools and your mouse, the Y translate values may be incorrect for your particular model. You may want to continue positioning the objects by visual reference using your mouse.

   Using the duplicate options is an alternate method for positioning and scaling duplicated objects when you can anticipate its final location.

Fig 2.46
4. In the Channel Box, rename the duplicated cube columnCapital.

The base for the column rests on top of the pedestal. You will create the base using one half of a NURBS sphere primitive and then move and rotate it into position. You will do this by modifying the creation options for the sphere primitive.

**To create a NURBS sphere for the column base**

1. Select Create > NURBS Primitives > Sphere >.

The NURBS Sphere Options window appears.

**Note**

If the NURBS Sphere Options window does not appear, make sure you have Create > NURBS Primitive > Interactive Creation turned off and then try again.

2. In the NURBS Sphere Options window, select Edit > Reset Settings and then set the following options:
   - Start Sweep Angle : 0
   - End Sweep Angle : 180
   - Radius : 0.75
   - Number of Sections : 8
   - Number of Spans : 4

Leave the other options at their default settings.

3. In the NURBS Sphere Options window, click Create.

Maya creates a half-sphere primitive at the origin.

The sphere needs to be rotated 90 degrees and then positioned on top of the pedestal.

**To rotate and position the sphere on the pedestal**

1. In side view, rotate the sphere so that the dome part is pointing up.

This is accomplished by either of the following methods:

- Rotating the sphere about the X axis using the Rotate Tool’s manipulator handle.
- Using the Channel Box to change the Rotate X value to -90.
2. Move the sphere so it rests on the top surface of columnPedestal (Translate Y = 2.6, if you have been inputting values into the Channel Box).

3. Using the Scale Tool, scale the sphere along its Z axis (blue manipulator handle) so that the sphere becomes slightly squashed in appearance.

When you scale an object non-uniformly along one of its axes, you are scaling it non-proportionally.

4. In the Channel Box, rename the sphere columnBase.

**Viewing objects in shaded mode**

Up to this point, you have been viewing your objects in the default wireframe mode. In wireframe mode, objects appear transparent except for the
simple wire outline that indicates their position and general shape. Maya provides several options for displaying objects in a shaded manner.

![Fig 2.49](image)

Change the display of your scene so that the objects display as shaded objects.

**To display the objects in smooth shaded mode**

1. Enlarge your perspective view, and dolly and tumble the scene so you can easily view what you’ve completed so far.

2. From the panel menu, select Shading > Smooth Shade All.

The objects in your scene display in an opaque dark gray color. You can work with objects in either shaded or unshaded mode for the balance of this lesson.

**Grouping objects**

When you need to move, scale or rotate multiple objects as one unit it is easier if they have been grouped together so that they transform as one unit.

Many primitive objects in Maya are grouped objects. For example, the NURBS cube primitive is comprised of 6 flat squares or planes that have been grouped together as one unit. When the plane objects are grouped together they create a hierarchy.

A hierarchy is a collection of nodes or objects that are connected together to form a unit for some purpose. Hierarchies are useful for describing how the
objects within them share similar characteristics or attributes; move, scale, rotate for example.

To group the objects for the column

1. Select the four objects that comprise the column simultaneously by doing one of the following:
   - With your left mouse button, shift-click each object in turn until the four objects are selected in the scene view.
   - With your left mouse button, drag one large bounding box around the column objects in an orthographic view.

   It is important that you do not select any of the templeBase objects as part of your selection. If you accidentally select any of the base objects, deselect them.

2. From the main menu, select Edit > Group >.

3. In the Group Options window, select Edit > Reset Settings and then set the following options.
   - Group Under: Parent
   Leave the other options at their default settings

4. In the Group Options window, click Group.

Maya groups the objects together in a hierarchy. You will learn more about hierarchies in the steps that follow.

The Hypergraph

The Hypergraph is a window that shows how the nodes and their connections are organized in your scene. You view object hierarchies and dependencies in the Hypergraph. Use the Hypergraph to view what happens when you group an object.

To view the Hypergraph

1. From the view menu, select Panels > Layouts > Two Panes Stacked.

   The scene view splits into two viewing panels - each has their own separate view menu. You will set these to view the scene in the upper view and the Hypergraph in the other.

2. From the lower pane menu, select Panels > Hypergraph Panel > Hypergraph Hierarchy.
The Hypergraph panel will display below the scene view panel.

3. At the top of the Hypergraph panel, select the Scene Hierarchy icon to ensure the Hypergraph is displaying the scene hierarchy.

4. In the Hypergraph panel, select View > Frame All.

The Hypergraph displays the hierarchy for all of the objects in the scene. This approach to viewing the entities in the scene provides a very graphical approach to viewing all of the various nodes in your scene.

In the Hypergraph, each node is represented as a rectangle labelled with an icon that denotes the type of information it represents (for example, surface, shading, and so on). Each node has a unique name assigned to it when it is first created. When you rename your objects, you are actually renaming the node associated with that object.

Some nodes display with a line connecting them. This denotes that they are in a hierarchy and have a dependency structure based on how they were originally grouped.
For the temple’s column objects, the hierarchy displays each of the named objects under a node labelled group1. Group1 is the parent node for this hierarchy of objects.

In Maya, when the parent node (sometimes referred to as the root node) is moved, rotated, or scaled in any way, the child nodes (sometimes referred to as the leaf nodes) underneath are also affected.

When you select objects at the top level of a hierarchy and move them, the objects within the hierarchy or group follow.

Note

This system of nodes, attributes, and hierarchies may initially appear somewhat complex, but it is one of the most powerful features of Maya. The node based architecture provides flexibility and power to create complex models, shaders, and animations.

To rename the parent node in the Hypergraph

1. In the Hypergraph, click on the group1 node so it becomes active.

In the scene view, all of the objects in the column group become selected as a result of selecting the group at the top (parent) level of the hierarchy.

2. In the Hypergraph, right-click the top node representing group1 and select Rename from the pop-up menu.

A small text box appears in the node.

3. Enter Column as the new name.

Now that the column is grouped, you need to position it at one corner of the temple base.

To position the column on the temple base

1. Change the display of objects to wireframe mode by tapping the 4 key on your keyboard.

This is a keyboard shortcut. Instead of selecting the item from the menu you can use a single key to implement the command.

Tip

Many of the tools and features in Maya can be accessed using keyboard shortcuts. In Maya, these shortcuts are called Hotkeys. Some Hotkeys are displayed directly beside the menu item, others are listed in the Hotkey Editor.
For a complete listing of available hotkeys, go to Window > Settings/Preferences > Hotkey Editor.

2. In the Hypergraph, select the Column at the top node so that Column becomes active in the scene view.

3. In the scene view, use the Move Tool to position Column at the front corner of the temple base as shown below.

With your first column in position, you can now create a copy of the column and position it on the adjacent corner of the base.

To create a duplicate copy of the column

1. With Column still selected in the Hypergraph, select Edit > Duplicate Special > from the main menu.

   The Duplicate Special Options window appears.

2. In the Duplicate Special Options window, select Edit > Reset Settings and then set the following options:
   - Number of Copies : 1

   Leave the other options at their default settings.

3. In the Duplicate Special Options window, click Duplicate Special.

   The Hypergraph view updates to show an additional column object in the scene. The copy also takes on the prefix name of the original group and is now labelled Column1.

   In the scene view it appears that nothing was actually duplicated. When an object is duplicated without any transformations the copy is positioned in the same position as the original. The two objects are on top of each other.
You need to move the column into position on the adjacent corner of the temple base.

**To move the duplicate column into position on the base**

![Two column in position](image)

1. In the Hypergraph, ensure Column1 is selected by clicking on its top node so it becomes selected in the scene view.

2. In the scene view, use the Move Tool to position Column1 on the adjacent corner of the temple base as shown below.

3. From the Toolbox, click the Four View layout shortcut.

   The workspace changes to a four view layout and the Hypergraph is no longer displayed.

**Selection modes and masks**

It isn’t always efficient to have the Hypergraph window open when you want to select an object at a particular level within its hierarchy. Maya allows you to select items in different selection modes depending upon your specific needs.

There are three main types of selection modes: Hierarchy, Object and Component. You use these modes in order to mask or limit the selection of other objects in order to select only the types of items you want. When you use a selection mask you are filtering out or masking items you don’t want to be chosen as part of the selection.

The icons for the three modes appear on the Status Line.
When you first start Maya, the default selection mode is set to Objects. This is useful for much of your selection work with Maya, with a few exceptions. When you want to select items that have been grouped, set the selection mode to Hierarchy.

**Tip**

If you set the selection mask, it will remain that way until you change it again. If an item won’t select for you in Maya, you should check the selection mask setting to see if it is set correctly.

**To use the Hierarchy and Combinations selection mask**

1. On the Status Line, choose the Select by Hierarchy and Combinations icon.
   
   The Selection Mask icons update to display the three selection choices.

2. On the Status Line, choose the Select by hierarchy: Root icon.

Select by hierarchy: Root ensures that when you select items they are selected at their parent or root node.
1. In the scene view, shift-click Column and Column1 so they are selected simultaneously. (Do not be concerned that they highlight in different colors.)

**Pivot points**

A pivot point is a specific position in 3D space that is used as a reference for the transformations of objects. All objects (curves, surfaces, groups) have pivot points.

When you group objects in Maya, a new node called a parent node is created for the group of objects. The pivot point for the group’s parent node is placed at the origin (0, 0, 0). This is useful if you later want to duplicate and rotate the objects radially (that is, in a circular fashion around the pivot).

**To group the two columns**

1. Ensure Column and Column1 are selected.

2. From the main menu, select Edit > Group >.

3. In the Group Options window, select Edit > Reset Settings. Set the following options:

   • Group Under: Parent

4. In the Group Options window, click Group.

   Maya groups the objects together in a hierarchy and the pivot point is positioned at the origin. (When the pivot point is relocated to the origin the Move Tool manipulator for the selected group appears at the origin.)

   With the two columns grouped, you then duplicate the columns with a rotation option, the groups will duplicate and rotate around the pivot point at the origin (0, 0, 0).

**To duplicate and rotate the group**

1. With column group selected, select Edit > Duplicate Special > from the main menu.

2. In the Duplicate Special Options window, select Edit > Reset Settings and then set the following options:

   • Rotate: 0 90 0

   • Number of Copies: 3

3. In the Duplicate Special Options window, click Duplicate Special.
The columns are duplicated and rotated by 90 degrees with each copy.

![Diagram of column groups duplicated and rotated 90 degrees](image)

Each column group is duplicated and copied 90 degrees

Fig 2.56

**Save your work**

Your temple is taking shape! Save your work before proceeding to the next lesson.

**To save your Maya scene**

1. To save your Maya scene, select File > Save Scene As.
2. Type Lesson3Columns in the file browser area reserved for file names.
3. Click Save.

**Beyond the lesson**

In this lesson, you explored additional tools and skills within Maya as you continued with the construction of the classic temple. In this lesson you learned how to:

- Use your mouse to change the view of your scene using the dolly, track, and tumble camera tools in both the orthographic and perspective views.
- Rotate objects using the transformation tools in the Toolbox and the Channel Box.
- Group objects so they can be transformed as a unit.
- Display objects in both wire frame and shaded modes.
• Access the Hypergraph to view nodes and hierarchies. You are also learning that many tasks in Maya can be completed or approached using multiple techniques.

• Rename nodes within the Hypergraph.

• Select objects in your scene using the Hypergraph.

• Use the group pivot point to your advantage when duplicating objects.

• Before proceeding with the next lesson you may want to review the material presented in this lesson so you are familiar with the concepts and skills associated with them. Some suggested tasks you can try on your own include

• Practice using the view camera tools (dolly, track, and tumble) so you can navigate within the scene views efficiently.

• Practice moving and rotating objects, and changing between the various scene views (single perspective, four view, single side, single top, and so on).

• View objects in the Hypergraph so you can understand their relationships and hierarchy.

**Topic 4 Components and attributes**

Working with components is an important part of the workflow when working in Maya. Components describe objects at a more detailed level. As you edit the components of your classic temple, you will learn more about what is possible in Maya.

In this lesson you learn how to:

• Template objects in the scene.

• Understand the difference between objects and components.

• Edit objects at their component level.

• Assign surface material attributes

• Access the Attribute editor

**Template display**

When your scene becomes complex, templating the display of some of the objects in your scene allows you to more easily select only the objects you
want. When you template the display of an object, its wireframe changes to a gray color. The object(s) can still be seen, but not easily selected. This helps to prevent you from selecting or modifying it accidentally. You can change the display of objects to a template and use them as a modeling reference (the way a grid is used).

You need to change the display of the base and columns to template mode so that you can more easily work on the temple roof.

**To template the base and columns**

1. In the side view, with the Selection Mask set to Hierarchy, select all the objects in your scene.

2. From the main menu, select Display > Object Display > Template.

**The selected objects become templated.**

For your classic temple, you need to create the entablature using a torus primitive. An entablature is a structure that lies horizontally upon the columns of a temple and supports the roof.

![Fig 2.57](image)

**To create and position a torus primitive for the entablature**

1. From the main menu, select Create > NURBS Primitives > Torus >.

2. In the NURBS Torus Options window, select Edit > Reset Settings and then set the following options:
• Radius : 8.5  
• Minor Radius : 0.5  
• Number of Sections : 24  

3. In the NURBS Torus option window, click Create.

Note

If the NURBS Primitives Options window does not appear, ensure that a check mark does not appear beside the Interactive Creation menu item before selecting Create > NURBS Primitives > Torus > by first selecting Create > NURBS Primitives > Interactive Creation.

4. In the Channel Box, rename the torus primitive Entablature.

5. Move the entablature vertically in the scene so it rests on top of the columns (Translate Y = 9.7).

Components

All objects in Maya have a transform and a shape node. Geometric shapes, like the primitives in this tutorial, have smaller parts called components.
A few examples of components in Maya are control vertices, faces, and hulls. Components allow you to work with objects at a finer level and allow you to edit them in creative ways.

In order to change the shape of the entablature beyond the basic scale transformations, you need to modify its component information.

**To select components of the entablature**

1. In the side view, dolly in for a closer view of Entablature.
2. Set the Selection Mode to Component mode.
3. Right-click the wireframe of Entablature and select Control Vertex from the pop-up menu.
The menu that pops up is a marking menu for quickly selecting operations relevant to the object where you right-click the mouse. In this case, the choices pertain to the display of the entablature’s components.

A set of small blue squares appear on Entablature called control vertices. Control Vertices (CVs) describe the shape of an object based on their position in space. If you move any combination of these vertices, you change the shape of the object.

4. Drag a selection box around the top row of vertices so they become selected.

5. Using the Move Tool, move the vertices up vertically as shown below to change the shape of Entablature.

6. To cancel the display of the CVs, right-click the wireframe of Entablature once again and select Object Mode from the pop-up menu.

The roof for the temple rests on top of the entablature. The roof for the temple is created using one half of a sphere primitive.

To create a roof for the temple

1. Select Create > NURBS Primitives > Sphere >.
2. In the NURBS Sphere Options window, select Edit > Reset Settings and then set the following options:

- Start Sweep Angle : 0
- End Sweep Angle : 180
- Radius : 8.75
- Number of Sections : 8
- Number of Spans : 4

In the NURBS Sphere Options window, click Create.

3. Rename the half-sphere templeRoof.

The roof needs to be rotated -90 degrees about the X axis and positioned on top of the entablature.

To rotate and position the roof on the entablature

1. In side view, rotate the roof so that the dome part is pointing up.
2. Move the roof so it is positioned close to the top edge of Entablature.
3. Scale the roof along its Z axis (blue manipulator handle) so that the sphere becomes slightly squashed in appearance.
Now that the roof is complete, you can untemplate the templated objects.

**To untemplate objects**

1. On the Status Line, choose the Select by Hierarchy and Combinations button.

2. On the Status Line, choose the Select by hierarchy: template button.

Select by hierarchy: template ensures that only templated objects will be affected by a selection.

1. In the scene view, drag a selection box around all the objects in the scene so that the templated objects are selected simultaneously.

2. From the main menu, select Display > Object Display > Untemplate.

3. On the Status Line, choose the Select by hierarchy: root button.

**The Attribute Editor**

The Attribute Editor provides information about the various nodes and attributes for the objects and materials in your scene. Like the Channel Box, you can view and edit the basic transform information and many other keyable attributes. However, the Attribute Editor provides a more detailed display of all attributes for a selected object.

**To view object attributes using the Attribute Editor**

1. In the scene view, select templeRoofso it becomes the selected object.

2. To view the Attribute Editor, click the Show/Hide icon on the Status Line.
The Attribute Editor displays the attributes for templeRoof. The various attributes for the templeRoof object appear under various tabs. Each tab represents a node.
3. **Click the temple Roof tab to see its attributes.**

   This tab is known as the transform node, because the most important attributes on this tab control templeRoof’s transformation. Every visible object in Maya has a transform node, including cameras and lights.

4. **Click the temple Roof Shape tab to see its attributes.**

   This tab is called the shape node because the attributes establish the object’s geometric shape or physical properties when the object is first created. Most objects have shape nodes, some do not, such as the group for the column objects. The shape node also includes other types of attributes, such as object display attributes.

5. **Click the make Nurb Sphere tab to see its attributes.**

   This is an input node that includes attributes related to the object’s construction history. The attributes of an input node are passed to another node subsequent in the construction history for the object—in this case, to the templeRoofShape node.

6. The last two nodes are initialShadingGroup and lambert1. If you can’t see them, click the display arrow.

   The initialShadingGroup and lambert1 nodes are default nodes that relate to the default shading material for an object. Maya uses them to establish the initial color of objects and other settings related to shading. If you create your own shading materials for the temple, as you will in the following steps, these nodes are replaced by the new shading nodes you create.

**Surface materials**

The color, shininess, and reflectivity attributes of an object are controlled by its surface material (sometimes referred to as a shader, or shading material). Material attributes relate to how the object simulates a natural reaction to light in Maya’s 3D computer world.

Maya assigns a default shading material to all objects when they are first created. In this section, you learn how to assign a new material to your objects.

**To assign a new material to the temple objects**

1. Right-click the wireframe of Entablature and select Object Mode from the pop-up menu.
This changes the selection mask back to objects so you can select objects in the scene. It is a shortcut to access this feature.

2. Drag a selection box around all the objects in your scene to select them.

Tip

If objects won’t select in the Maya scene, check that your selection mask is set correctly on the Status Line.

1. From the Status Line, select the Rendering menu set using the menu selector.

The main menu changes to display the menu set for Rendering.

2. From the main menu, select Lighting/Shading > Assign New Material.

The Assign New Material window appears.
3. In the materials list on the right, select Blinn.

A Blinn shading material is assigned to all the objects in the scene and the Attribute Editor updates. Blinn shading materials (named after the inventor of this shading algorithm) provide for high-quality specular highlights on surfaces.

4. In the Attribute Editor, rename the blinn1 shading material to templeShader.

With a shading material assigned to all the objects, you need to edit the color attributes of the templeShader material.

To edit the shading material’s attributes

1. In the Attribute Editor, click in the gray box to the right of the word Color.
Fig 2.67

The mini Color Chooser appears.

Fig 2.68

2. Click the ring between yellow and orange to achieve a sand color. You can further refine this color by clicking a shade in the square palette.

The exact color is unimportant for this lesson. However, if you’d like more options for choosing your color, you can double-click the the gray box to display the full Color Chooser.

In either case, as you adjust the color wheel indicator, the temple objects become the same color you select in the Color Chooser.

3. Click Accept to close the chooser.
You will learn more about Maya’s shading and texturing capabilities in future lessons.

Fig 2.69

Fig 2.70 Persp
4. In the Attribute Editor menu, choose the Selected menu item, and select templeBase from the list.

![Fig 2.71](image)

The attributes for templeBase display in the Attribute Editor.

1. Click the templeShader node tab to see its attributes.

   If you can’t see this tab, click the display arrow to the right of the tabs.

   These are the same attributes you edited when you assigned the templeShader shader to all the objects in the scene. When you first create an object, you see two default nodes for shading, initialShadingGroup and lambert1. When you assign a shading material, the two default nodes are replaced by the attribute node for the assigned shading material.

   You will encounter transform, shape, input, and shading nodes throughout your work with Maya. There are other types of nodes that you’ll learn about as you continue learning about Maya.

2. Close the Attribute Editor using the Show/Hide icon.

**Save your work**

You have completed this lesson. Save your work before proceeding.

**To save your Maya scene**

1. Select File > Save Scene As.

2. Type Lesson4Final in the file browser area reserved for file names, and then click Save.

In this lesson, you completed the construction of the classic temple and learned how to:

- Display objects in template mode.
- Select objects at their component level using selection masks and the right mouse button.
- Assign and edit shading materials for your objects in the scene.
• Access the Attribute editor and view the various node types for objects.

• As you proceed through Getting Started with Maya, we assume you are familiar with the fundamental concepts and skills covered in this first chapter.

• Before proceeding to the next chapter you may want to review the material presented in this lesson so you are familiar with the concepts and skills associated with them. Some suggested tasks you may want to do on your own

• Practice construction of additional forms using primitive shapes by creating. Additional details for your temple scene (stairs, roof details, etc.).

Summary

Autodesk Maya, commonly shortened to Maya, is 3D computer graphics software that runs on Windows, Mac OS and Linux, originally developed by Alias Systems Corporation (formerly Alias|Wavefront) and currently owned and developed by Autodesk, Inc.

It is used to create interactive 3D applications, including video games, animated film, TV series, or visual effects. The product is named after the Sanskrit word Maya, it means illusion. In this unit the student got exposed to various basic tools and commands of Autodesk Maya user interface, and also exposed to various topic areas like The Maya user interface in detail, Creating, manipulating, and viewing objects, Viewing the Maya 3D scene, Components and attributes:

Short Answer Type Questions

1. Write about Autodesk Maya in general.

2. List other important 3d modeling and animation software, similar to Maya.

3. What are various file formats associated with Maya.

4. What are Primitives in Maya?

Long Answer Type Questions

1. Explain the UI of Maya.

2. List all important modules available in Maya. (Like Modeling etc.)

3. List important shortcut keys of transformations (Ex. Move, Scale etc.)
Learning Objectives

In this unit the student will about modeling fundamentals with a special focus to solid drawing, appeal, Polygons, NURBS and sub divisional surfaces and also a little introduction about 3d digital sculpting.

What is 3d Modeling?

3D modeling is the process of creating a representation of a three-dimensional object with the assistance of a special computer software. The two-dimensional representation of a 3D model is called rendering.
All about solid drawing:

The principle of solid drawing means taking into account forms in three-dimensional space, giving them volume and weight. The animator needs to be a skilled draughtsman and has to understand the basics of three-dimensional shapes, anatomy, weight, balance, light and shadow, etc. For the classical animator, this involved taking art classes and doing sketches from life. One thing in particular that Johnston and Thomas warned against was creating “twins”: characters whose left and right sides mirrored each other, and looked lifeless. Modern-day computer animators draw less because of the facilities computers give them, yet their work benefits greatly from a basic understanding of animation principles, and their additions to basic computer animation.

![Fig 3.2](image)

What is Charisma?

The term charisma has two senses

1. Compelling attractiveness or charm that can inspire devotion in others,

2. A divinely conferred power or talent.

For some theological usages the term is rendered charisma, with a meaning the same as sense 2. Since the 1950s, the term has become widely used, with varying meanings, in religion, the social sciences, the media, and throughout Western societies. This article describes the theological and personality senses of the definition of charisma, the history of the term, and 21st century uses of both senses in particular sectors of society.
Appeal in Animation Terminology

A live performer has charisma. An animated character has appeal. Appealing animation does not mean just being cute and cuddly. All characters have to have appeal whether they are heroic, villainous, comic or cute. Appeal, as you will use it, includes an easy to read design, clear drawing, and personality development that will capture and involve the audience’s interest.

Early cartoons were basically a series of gags strung together on a main theme. Over the years, the artists have learned that to produce a feature there was a need for story continuity, character development and a higher quality of artwork throughout the entire production. Like all forms of storytelling, the feature has to appeal to the mind as well as to the eye.

Polygonal Modeling

Constructive solid geometry (CSG) is a technique used in solid modeling. Constructive solid geometry allows a modeler to create a complex surface or object by using Boolean operators to combine objects. Often CSG presents a model or surface that appears visually complex, but is actually little more than cleverly combined or recombined objects.

In 3D computer graphics and CAD CSG is often used in procedural modeling. CSG can also be performed on polygonal meshes, and may or may not be procedural and/or parametric.
Non-uniform rational basis spline (NURBS) is a mathematical model commonly used in computer graphics for generating and representing curves and surfaces. It offers great flexibility and precision for handling both analytic (surfaces defined by common mathematical formulae) and modeled shapes.

Subdivision surface

A subdivision surface, in the field of 3D computer graphics, is a method of representing a smooth surface via the specification of a coarser
piecewise linear polygon mesh. The smooth surface can be calculated from the coarse mesh as the limit of a recursive process of subdividing each polygonal face into smaller faces that better approximate the smooth surface.

![Image of polygon mesh subdivision](image)

**Fig 3.6**

**Digital or 3d Sculpting:**

Digital sculpting, also known as Sculpt Modeling or 3D Sculpting, is the use of software that offers tools to push, pull, smooth, grab, pinch or otherwise manipulate a digital object as if it were made of a real-life substance such as clay.

**Sculpting Technology**

The geometry used in digital sculpting programs to represent the model can vary; each offers different benefits and limitations. The majority of digital sculpting tools on the market use mesh-based geometry, in which an object is represented by an interconnected surface mesh of polygons that can be pushed and pulled around.

This is somewhat similar to the physical process of beating copper plates to sculpt a scene in relief. Other digital sculpting tools use voxel-based geometry, in which the volume of the object is the basic element. Material can be added and removed, much like sculpting in clay. Still other tools make use of more than one basic geometry representation.
A benefit of mesh-based programs is that they support sculpting at multiple resolutions on a single model. Areas of the model that are finely detailed can have very small polygons while other areas can have larger polygons. In many mesh-based programs, the mesh can be edited at different levels of detail, and the changes at one level will propagate to higher and lower levels of model detail. A limitation of mesh-based sculpting is the fixed topology of the mesh; the specific arrangement of the polygons can limit the ways in which detail can be added or manipulated.

A benefit of voxel based sculpting is that voxels allow complete freedom over form. The topology of a model can be altered continually during the sculpting process as material is added and subtracted, which frees the sculptor from considering the layout of polygons on the model’s surface. Voxels, however, are more limited in handling multiple levels of detail. Unlike mesh-based modeling, broad changes made to voxels at a low level of detail may completely destroy finer details.

Interaction with digital sculpting tools can vary from the standard computer mouse to a digital pen tablet that provides pressure sensitivity, which can provide added functionality for most sculpting software. Some tools even support sculpting with haptic input devices, which allow the sculptor to feel the digital object while sculpting.

**Sculpting Programs**

There are a number of digital sculpting tools available. Some popular tools for creating are:

<table>
<thead>
<tr>
<th>3D-Coat</th>
<th>Mudbox</th>
</tr>
</thead>
<tbody>
<tr>
<td>Aartform Curvy 3D</td>
<td>Sculptris</td>
</tr>
<tr>
<td>Blender</td>
<td>SharpConstruct</td>
</tr>
<tr>
<td>CB model pro</td>
<td>Silo</td>
</tr>
<tr>
<td>Freeform</td>
<td>ZBrush</td>
</tr>
<tr>
<td>Modo</td>
<td>Cinema 4D R14</td>
</tr>
</tbody>
</table>
Summary

In Maya, modeling refers to the process of creating virtual 3D surfaces for the characters and objects in the Maya scene. Surfaces are vital for creating a convincing 3D image.

Modeling is a process requiring keen visual skills and mastery of the modeling tools. The more accurate you are when modeling your forms in terms of size, shape, detail, and proportion, the more convincing your final scene will be.

There are three modeling surface types in Maya

- Polygons
- NURBS
- Subdivision surfaces.

Each surface type has particular characteristics and benefits. In this session students got introduced all core modeling theoretical concepts in detail.

Short Answer Type Questions

1. Define 3d Modeling.

2. What is the use of Mudbox software?

3. Difference between sculpting and 3d sculpting.
4. What is voxel based geometry?

5. Define Polygonal, NURBS and Sub Divisional Surface modeling techniques in brief.

**Long Answer Type Questions**

1. What is the importance of solid drawing in Animation?

2. Define Appeal and its importance in Animation Arena.

3. What is digital sculpting? Write in brief with proper examples?

4. List important Sculpting Software Programs.

5. What is the role of Modeling in 3d Animation project pipeline?
Learning Objectives

In this session the student will get exposed to texture mapping techniques and also its concepts in general. After completing this module the student will be capable of doing the following:

• Can apply labels and logos to your surfaces.

• Can apply surface relief details and features to a surface instead of having to model the details on the surface directly.

• Can use illustrations as texture maps to create interesting backdrops in scenes.

What is texturing

Texture mapping is a method for adding detail, surface texture (a bitmap or raster image), or color to a computer-generated graphic or 3D model. Its application to 3D graphics was pioneered by Edwin Catmull in 1974.

All about texture mapping:

A texture map is applied (mapped) to the surface of a shape or polygon.[1] This process is akin to applying patterned paper to a plain white box. Every vertex in a polygon is assigned a texture coordinate (which in the 2d case is also known as a UV coordinate) either via explicit assignment or by procedural definition. Image sampling locations are then interpolated across the face of a polygon to produce a visual result that seems to have more richness than could otherwise be achieved with a limited number of polygons.
Introduction to materials and shading

What is shading?

Shading refers to depicting depth perception in 3D models or illustrations by varying levels of darkness.

Shading is a process used in drawing for depicting levels of darkness on paper by applying media more densely or with a darker shade for darker areas, and less densely or with a lighter shade for lighter areas. There are various techniques of shading including cross hatching where perpendicular lines of varying closeness are drawn in a grid pattern to shade an area. The closer the lines are together, the darker the area appears. Likewise, the farther apart the lines are, the lighter the area appears.

Light patterns, such as objects having light and shaded areas, help when creating the illusion of depth on paper.

What is shading in computer Graphics

In computer graphics, shading refers to the process of altering the color of an object/surface/polygon in the 3D scene, based on its angle to lights and its distance from lights to create a photorealistic effect. Shading is performed during the rendering process by a program called a shader.
What is reflection?

Reflection is the change in direction of a wavefront at an interface between two different media so that the wavefront returns into the medium from which it originated. Common examples include the reflection of light, sound and water waves. The law of reflection says that for specular reflection the angle at which the wave is incident on the surface equals the angle at which it is reflected. Mirrors exhibit specular reflection.

Primary Material Properties

*About computer color:* HSL and HSV are the two most common cylindrical-coordinate representations of points in an RGB color model. The two representations rearrange the geometry of RGB in an attempt to be more intuitive and perceptually relevant than the cartesian (cube) representation. Developed in the 1970s for computer graphics applications, HSL and HSV are used today in color pickers, in image editing software, and less commonly in image analysis and computer vision.

HSL stands for hue, saturation, and lightness, and is often also called HLS. HSV stands for hue, saturation, and value, and is also often called HSB (B for brightness). A third model, common in computer vision applications, is HSI, for hue, saturation, and intensity. However, while typically consistent, these definitions are not standardized, and any of these abbreviations might be used for any of these three or several other related cylindrical models.
What is Specularity?

Specularity refers the smoothness of a surface. A highly specular surface is very smooth. Due to misinterpretation of this word, 3D graphics artists mistakenly use the word to mean “the reflection of a light” or “light highlight” as outlined below. This usage has become common in the world of 3D computer graphics but is becoming confusing as more physically based rendering engines are using the word correctly to describe the smoothness of materials, not the reflected highlight of a light source.

What is reflection?

Specular reflection is the mirror-like reflection of light (or of other kinds of wave) from a surface, in which light from a single incoming direction (a ray) is reflected into a single outgoing direction.

What is refraction?

Refraction is the change in direction of a wave due to a change in its medium. It is essentially a surface phenomenon. The phenomenon is mainly in governance to the law of conservation of energy and momentum. Due to change of medium, the phase velocity of the wave is changed but its frequency remains constant. This is most commonly observed when a wave passes from one medium to another at any angle other than 90° or 0°. Refraction of light is the most commonly observed phenomenon, but any type of wave can refract when it interacts with a medium, for example when sound waves pass from one medium into another or when water waves move into water of a different depth.
What is transparency?

In the field of optics, transparency is the physical property of allowing light to pass through the material without being scattered.
Surface Characteristics:

What is Texture / Surface Relief?

In the visual arts, texture is the perceived surface quality of a work of art. It is an element of two-dimensional and three-dimensional design and is distinguished by its perceived visual and physical properties. Use of texture, along with other elements of design, can convey a variety of messages and emotions.

There are two varieties of textures

1. **Visual**: Visual texture is the illusion of having physical texture.

2. **Hypertexture**: Hypertexture can be defined as both the “realistic simulated surface texture produced by adding small distortions across the surface of an object.”

What is texture mapping?

The application of patterns or images to three-dimensional graphics to enhance the realism of their surfaces.

What is Bump mapping?

Bump mapping is a technique in computer graphics for simulating bumps and wrinkles on the surface of an object. This is achieved by perturbing the surface normals of the object and using the perturbed normal during lighting calculations. The result is an apparently bumpy surface rather than a smooth surface although the surface of the underlying object is not actually changed. Bump mapping was introduced by Blinn in 1978.

Fig 4.6 Bump mapping
What is displacement mapping?

Displacement mapping is an alternative computer graphics technique in contrast to bump mapping, normal mapping, and parallax mapping, using a (procedural-) texture- or height map to cause an effect where the actual geometric position of points over the textured surface are displaced, often along the local surface normal, according to the value the texture function evaluates to at each point on the surface.

![Original mesh](image1)

![Displacement map](image2)

![Mesh with displacement](image3)

Fig 4.7 Displacement mapping

What is normal mapping?

In 3D computer graphics, normal mapping, or “Dot3 bump mapping”, is a technique used for faking the lighting of bumps and dents - an implementation of Bump mapping. It is used to add details without using more polygons. A common use of this technique is to greatly enhance the appearance and details of a low polygon model by generating a normal map from a high polygon model or height map.

Normal maps are commonly stored as regular RGB images where the RGB components corresponds to the X, Y, and Z coordinates, respectively, of the surface normal.
Summary

Texture maps let you modify the appearance of your 3D models and scenes in Maya. Texture maps are images you apply and accurately position onto your surfaces using a process called texture mapping. When an image is texture mapped onto a surface, it alters the appearance of the surface in some unique way.

Texture maps let you create many interesting visual effects

- You can apply labels and logos to your surfaces.
- You can apply surface relief details and features to a surface instead of having to model the details on the surface directly.
- You can use illustrations as texture maps to create interesting backdrops in your scenes.

Most shading attributes for a surface material can be altered by a texture map. For example, color, specular, transparency, and reflectivity are examples of attributes that can be modified by a texture map. Texture mapping is a key component in the 3D production workflow. Many production environments employ texture artists whose only role is to create and apply the texture maps to 3D models.

Short Answer Type Questions

1. What is Bump Map?
2. What is Normal Map?
3. Define Texture.
4. What is the role of Lighting in Texture mapping?
5. Write about Tint, Tone and Shade in general.

Long Answer Type Questions

1. Write about mapping in general.
2. Differentiate Opaque and Transparency with proper examples.
3. What is Texturing?
4. Write about Displacement Map in detail.
5. Write about Various mapping techniques in Maya.
**Learning Objectives**

The concept of lighting involves basics of color theory as they relate to the aesthetic (emotional) influence on the viewer. Knowledge of natural and artificial light sources in the real-world, impact of color temperature on CG imagery, contrast for film and TV media, techniques of high-key, low-key and three-point lighting on an object or character, standard properties of shadow, different lighting techniques used in cinematography. By the time when student finishes this unit he/she will get good knowledge of the above said points.

**Concepts of Color**

**Why study color theory**

If you are involved in the creation or design of visual documents, an understanding of color will help when incorporating it into your own designs. Choices regarding color often seem rather mystical; as many seem to base decisions on nothing other than “it looks right.” Although often told I had an eye for color, the reason why some colors worked together while others did not always intrigued me and I found the study of color theory fascinating.

**Communicating Color**

What is red? Candy apple red, blood red, catsup red, rose red… to try and communicate a specific hue is difficult without some sort of coding system. Early in the 1900’s, Albert Munsell, a professor at an art school in Boston developed a color system which offered a means to name colors. With a published system, people could be specific about which red they were referring. Munsell’s
system has been reworked for today’s use with the Pantone color system, True match, CIE systems and others.

**Color Application**

With respect to the arts, color was part of the realistic, visual representation of form, but one group of painters abandoned the traditional practices regarding color in painting. This group of artists was influenced by Cezanne, Van Gogh, and Gauguin. Led by Henri Matisse, they were known as the Fauves, or “the wild beasts.” Their exuberant use of brilliant hues seems to disregard imitative color.

Whereas other artists had used color as the description of an object, the Fauves let color become the subject of their painting. A painting in the “Fauvist Manner” was one that related color shapes; rather than unifying a design with line, compositions sought expressiveness within the relationships of the whole. This turn from tradition brought integrity to color in that color was regarded on its own merit.

*For further information please refer to Graphic Designing Paper color theory:

**Lighting or illumination**

Lighting or illumination is the deliberate use of light to achieve a practical or aesthetic effect. Lighting includes the use of both artificial light sources like lamps and light fixtures, as well as natural illumination by capturing daylight. Daylighting (using windows, skylights, or light shelves) is sometimes used as the main source of light during daytime in buildings.

This can save energy in place of using artificial lighting, which represents a major component of energy consumption in buildings. Proper lighting can enhance task performance, improve the appearance of an area, or have positive psychological effects on occupants.

Indoor lighting is usually accomplished using light fixtures, and is a key part of interior design. Lighting can also be an intrinsic component of landscape projects.
Color temperature applications

For lighting building interiors, it is often important to take into account the color temperature of illumination. For example, a warmer (i.e., lower color temperature) light is often used in public areas to promote relaxation, while a cooler (higher color temperature) light is used to enhance concentration in offices.

CCT dimming for LED technology is regarded as a difficult task, since binning, age and temperature drift effects of LEDs change the actual color value output. Here feedback loop systems are used for example with color sensors, to actively monitor and control the color output of multiple color mixing LEDs.
In Aquaculture, Digital photography, Photographic film, Desktop publishing, TV, video, and digital still cameras, Artistic application via control of color temperature, all these uses variety of color temperatures.

**Contrast**

Contrast is the difference in luminance and/or color that makes an object (or its representation in an image or display) distinguishable. In visual perception of the real world, contrast is determined by the difference in the color and brightness of the object and other objects within the same field of view. Because the human visual system is more sensitive to contrast than absolute luminance, we can perceive the world similarly regardless of the huge changes in illumination over the day or from place to place. The maximum contrast of an image is the contrast ratio or dynamic range.

Contrast is also the difference between the color or shading of the printed material on a document and the background on which it is printed, for example in optical character recognition.
Three-point lighting

Three-point lighting is a standard method used in visual media such as video, film, still photography and computer-generated imagery. By using three separate positions, the photographer can illuminate the shot’s subject (such as a person) however desired, while also controlling (or eliminating entirely) the shading and shadows produced by direct lighting.

The key light, as the name suggests, shines directly upon the subject and serves as its principal illuminator; more than anything else, the strength, color and angle of the key determines the shot’s overall lighting design.

In indoor shots, the key is commonly a specialized lamp, or a camera’s flash. In outdoor daytime shots, the Sun often serves as the key light. In this case, of course, the photographer cannot set the light in the exact position he or she wants, so instead arranges it to best capture the sunlight, perhaps after waiting for the sun to position itself just right.

The fill light also shines on the subject, but from a side angle relative to the key and is often placed at a lower position than the key (about at the level of...
the subject’s face). It balances the key by illuminating shaded surfaces, and lessening or eliminating chiaroscuro effects, such as the shadow cast by a person’s nose upon the rest of the face. It is usually softer and less bright than the key light (up to half), and more to a flood. Not using a fill at all can result in stark contrasts (due to shadows) across the subject’s surface, depending upon the key light’s harshness. Sometimes, as in low-key lighting, this is a deliberate effect, but shots intended to look more natural and less stylistic require a fill.

In some situations a photographer can use a reflector (such as a piece of white cardstock mounted off-camera, or even a white-painted wall) as a fill light instead of an actual lamp. Reflecting and redirecting the key light’s rays back upon the subject from a different angle can cause a softer, subtler effect than using another lamp.

The back light (a.k.a. the rim, hair, or shoulder light) shines on the subject from behind, often (but not necessarily) to one side or the other. It gives the subject a rim of light, serving to separate the subject from the background and highlighting contours.

Back light or rim light is different from a kick in that a kick (or kicker) contributes to a portion of the shading on the visible surface of the subject, while a rim light only creates a thin outline around the subject without necessarily hitting the front (visible) surface of the subject at all.

**Four point lighting:**

The addition of a fourth light, the background light, makes for a four-point lighting setup.

The background light is placed behind the subject(s), on a high grid, or low to the ground. Unlike the other three lights, which illuminate foreground elements like actors and props, it illuminates background elements, such as walls or outdoor scenery. This technique can be used to eliminate shadows cast by foreground elements onto the background, or to draw more attention to the background. It also helps to off-set the single eye nature of the camera, this means that it helps the camera give depth to the subject.
A shadow is an area where direct light from a light source cannot reach due to obstruction by an object. It occupies all of the space behind an opaque object with light in front of it. The cross section of a shadow is a two-dimensional silhouette, or reverses projection of the object blocking the light. The sun causes many objects to have shadows and at certain times of the day, when the sun is at certain heights, the lengths of shadows change.
An astronomical object casts human-visible shadows when its apparent magnitude is equal or lower than 4. Currently the only astronomical objects able to produce visible shadows on Earth are the sun, the moon and, in the right conditions, the planet Venus.

Lighting technique and aesthetics

- Background lighting
- Cameo lighting
- Fill light
- Flood lighting
- High-key lighting
- Key lighting
- Lens flare
- Low-key lighting
- Mood lighting
- Rembrandt lighting
- Stage lighting
- Soft light
To achieve the results mentioned above, a Lighting Director may use a number or combination of Video Lights. These may include the Redhead or Open-face unit, The Fresnel Light, which gives you a little more control over the spill, or The Dedolight, which provides a more efficient light output and a beam which is easier to control.

**Rendering**

3D rendering is the 3D computer graphics process of automatically converting 3D wire frame models into 2D images with 3D photorealistic effects or non-photorealistic rendering on a computer.

Rendering is the process of generating an image from a model (or models in what collectively could be called a scene file), by means of computer programs. Also, the results of such a model can be called a rendering. A scene file contains objects in a strictly defined language or data structure; it would contain geometry, viewpoint, texture, lighting, and shading information as a description of the virtual scene. The data contained in the scene file is then passed to a rendering program to be processed and output to a digital image or raster graphics image file.

The term “rendering” may be by analogy with an “artist’s rendering” of a scene. Though the technical details of rendering methods vary, the general challenges to overcome in producing a 2D image from a 3D representation stored in a scene file are outlined as the graphics pipeline along a rendering device, such as a GPU. A GPU is a purpose-built device able to assist a CPU in performing complex rendering calculations. If a scene is to look relatively realistic and predictable under virtual lighting, the rendering software should solve the rendering equation. The rendering equation doesn’t account for all lighting phenomena, but is a general lighting model for computer-generated imagery. ‘Rendering’ is also used to describe the process of calculating effects in a video editing program to produce final video output.

Rendering is one of the major sub-topics of 3D computer graphics, and in practice is always connected to the others. In the graphics pipeline, it is the last major step, giving the final appearance to the models and animation. With the increasing sophistication of computer graphics since the 1970s, it has become a more distinct subject.

Rendering has uses in architecture, video games, simulators, movie or TV visual effects, and design visualization, each employing a different balance of features and techniques. As a product, a wide variety of renderers are available. Some are integrated into larger modeling and animation packages, some are stand-alone, some are free open-source projects. On the inside, a renderer is a carefully engineered program, based on a selective mixture of disciplines related to: light physics, visual perception, mathematics and software development.
In the case of 3D graphics, rendering may be done slowly, as in pre-rendering, or in real time. Pre-rendering is a computationally intensive process that is typically used for movie creation, while real-time rendering is often done for 3D video games which rely on the use of graphics cards with 3D hardware accelerators.
Rendering methods include the following: (instructor explains in detail)

- Scanline Rendering
- Ray Casting
- Ray Tracing
- Radiosity
- Stereoscopy

What are Render layers/Passes?

When creating computer-generated imagery or 3D computer graphics, final scenes appearing in movies and television productions are usually produced by Rendering (computer graphics) more than one “layer” or “pass,” which are multiple images designed to be put together through digital compositing to form a completed frame.

Rendering in passes is based on traditions in Motion control photography which pre-date CGI. As an example, in motion control photography for a visual effects shot, a camera could be programmed to move past a physical model of a spaceship in one pass to film the fully lit beauty pass of the ship, and then to repeat exactly the same camera move passing the ship again to photograph additional elements such as the illuminated windows in the ship or its thrusters. Once all of the passes were filmed, they could then be optically printed together to form a completed shot.

The terms “Render Layers” and “Render Passes” are sometimes used interchangeably. However, rendering in layers refers specifically to separating different objects into separate images, such as a foreground characters layer, a sets layer, a distant landscape layer, and a sky layer. Rendering in passes, on the other hand, refers to separating out different aspects of the scene, such as shadows, highlights, or reflections, each into a separate image.

Rendering Effects

Provide an overview of a range of effects rendering techniques that add realism to an image or scene such as textured elements, caustics, global illumination, camera effects, motion blur, HDR, atmospheric effects and non-photorealistic effects.

- Motion Blur
- Global Illumination
- Caustics
Summary

Firstly, Directors of live-action film use camera and lighting techniques to enhance the visual impact of a scene. Wide, medium, and close up views of the subject, depth of field, high or low key lighting all communicate something about the subject and the scene to the viewer.

Lighting and camera techniques are one of the most crucial aspects to consider when working with artificial characters and objects. The more realistic the lighting and shading appear, the more convincing the scene will appear to the viewer.

A prerequisite to creating effective 3D rendered animation is to study the lighting and camera effects used in live-action film. Your goal is to create the desired scene ambience while keeping the lights and camera view as unobtrusive as possible.

In Maya, it is possible to simulate both realistic and unrealistic lighting and shadow effects for your final images and animations. In this lesson, you learn basic techniques for working with lights, shadows, and cameras.

Secondly, in Maya, rendering refers to the process of creating bitmap images of your scene based on the various shading, lighting, and camera attributes that you set. When rendering, Maya takes into account all of the various objects and scene attributes, and performs mathematical calculations to produce the final image or image sequence. Once you render a sequence of images, you can then play them back in sequence, producing an animation.

Rendering involves many components to produce an image

- Shading materials and textures
- Lighting and shadows
- Cameras and animation
- Rendering method
- Visual effects

Short Answer Type Questions

1. What is the source of light?
2. Write about the effect of light in a scene.
3. Write about Albert Munsell in general.
4. Define Color and how it appears.

5. List various types of Lights in Maya.

Long Answer Type Questions

1. What is rendering?

2. List important renderers available in 3d animation software world.

3. Differentiate Mental Ray and Vector Renderer.

4. Write about Render Layers and Render Passes.

5. List important Rendering Effects.

6. What are the various rendering methods available in Maya?
Learning Objectives

A character rig is essentially a digital skeleton bound to the 3D mesh. Like a real skeleton, a rig is made up of joints and bones, each of which act as a “handle” that animators can use to bend the character into a desired pose. In this Unit the student will learn about methods of rigging and their applications.

A typical 3D character can be made up of many surfaces and components. To ensure that the character animates in the way that you want, it is important to carefully plan the process of character setup. Character setup or rigging is the general term used for the preparation of 3D models with their accompanying joints and skeletons for animation.

Depending on the model to be animated, character setup can involve the following techniques:

- Creating a skeleton with joints that acts as a framework for the 3D character model. You set limits on the joints so they rotate in a convincing manner. When you animate the character, you position the character’s joints using either forward or inverse kinematic techniques (FK or IK).

- Binding the 3D surfaces to the skeleton so that they move together. The process of binding may also include defining how the character’s joints bend or how the skin surfaces bulge to simulate muscles.

- Defining and setting constraints for particular animated attributes in order to restrict the range of motion or to control an attribute based on the movement of another.
• Grouping surface components such as CVs into sets called clusters so that parts of the character can be animated at a more detailed level.

**What is rigging in 3d Animation?**

When a modeler finishes building a character, it’s a static 3D mesh, almost like a marble sculpture.

Before a 3D character model can be handed over to the team of animators, it must be bound to a system of joints and control handles so that the animators can pose the model. This process is typically completed by artists known as character technical directors (TDs), or riggers.

Character TDs work closely with animators to make sure any specific technical issues are accounted for, but their primary duty is to take a static 3D mesh and make it ready for animation—a process called rigging.
Basic anatomy

(In this topic we review the basic components of the human body, including bones, muscles, and major organs.)

Human anatomy

Human anatomy is primarily the scientific study of the morphology of the human body.

Anatomy is subdivided into gross anatomy and microscopic anatomy.

Gross anatomy (also called topographical anatomy, regional anatomy, or anthroponomy) is the study of anatomical structures that can be seen by the naked eye.

Microscopic anatomy is the study of minute anatomical structures assisted with microscopes, which includes histology (the study of the organization of tissues), and cytology (the study of cells). Anatomy, human physiology (the study of function), and biochemistry (the study of the chemistry of living structures) are complementary basic medical sciences that are generally together (or in tandem) to students studying medical sciences.

In some of its facets human anatomy is closely related to embryology, comparative anatomy and comparative embryology, through common roots in evolution; for example, much of the human body maintains the ancient segmental pattern that is present in all vertebrates with basic units being repeated, which is particularly obvious in the vertebral column and in the ribcage, and can be traced from very early embryos.

The human body consists of biological systems, that consist of organs, that consist of tissues, that consist of cells and connective tissue.

The history of anatomy has been characterized, over a long period of time, by a continually developing understanding of the functions of organs and structures in the body. Methods have also advanced dramatically, advancing from examination of animals through dissection of fresh and preserved cadavers (dead human bodies) to technologically complex techniques developed in the 20th century.
Fig 6.2
Bipedal Anatomy

Biped Skeleton

Humans are born with over 270 bones, some of which fuse together into a longitudinal axis, the axial skeleton, to which the appendicular skeleton is attached.
Biped Muscles

Muscle is a kind of soft tissue of animals. Muscle cells contain protein filaments that slide past one another, producing a contraction that changes both the length and the shape of the cell. Muscles function to produce force and cause motion. They are primarily responsible for maintenance of and changes in posture, locomotion of the organism itself, as well as movement of internal organs, such as the contraction of the heart and movement of food through the digestive system via peristalsis.

Muscle tissues are derived from the mesodermal layer of embryonic germ cells in a process known as myogenesis. They are classified as skeletal, cardiac, or smooth muscles. Cardiac and smooth muscle contraction occurs without conscious thought and is necessary for survival. Voluntary contraction of the skeletal muscles is used to move the body and can be finely controlled. Examples are movements of the eye, or gross movements like the quadriceps muscle of the thigh.

Muscles are predominantly powered by the oxidation of fats and carbohydrates, but anaerobic chemical reactions are also used, particularly by fast twitch fibers. These chemical reactions produce adenosine triphosphate (ATP) molecules which are used to power the movement of the myosin heads.

The term muscle is derived from the Latin musculus meaning “little mouse” perhaps because of the shape of certain muscles or because contracting muscles look like mice moving under the skin.

Fig 6.4 Biped muscles
Kinematics

What is Kinematics? The features or properties of motion in an object, regarded in such a way.

There are two types of Kinematics

1. Forward Kinematics
2. Inverse Kinematics

In this unit we are going to discuss in details about the above said motion techniques.

**Forward kinematic**: Animation is a method in 3D computer graphics for animating models.

The essential concept of forward kinematic animation is that the positions of particular parts of the model at a specified time are calculated from the position and orientation of the object, together with any information on the joints of an articulated model. So for example if the object to be animated is an arm with the shoulder remaining at a fixed location, the location of the tip of the thumb would be calculated from the angles of the shoulder, elbow, wrist, thumb and knuckle joints. Three of these joints (the shoulder, wrist and the base of the thumb) have more than one degree of freedom, all of which must be taken into account. If the model were an entire human figure, then the location of the shoulder would also have to be calculated from other properties of the model.

Forward kinematic animation can be distinguished from inverse kinematic animation by this means of calculation - in inverse kinematics the orientation of articulated parts is calculated from the desired position of certain points on the model. It is also distinguished from other animation systems by the fact that the motion of the model is defined directly by the animator - no account is taken of any physical laws that might be in effect on the model, such as gravity or collision with other models.

**Inverse kinematics**: Refers to the use of the kinematics equations of a robot to determine the joint parameters that provide a desired position of the end-effector. Specification of the movement of a robot so that its end-effector achieves a desired task is known as motion planning. Inverse kinematics transforms the motion plan into joint actuator trajectories for the robot.

The movement of a kinematic chain whether it is a robot or an animated character is modeled by the kinematics equations of the chain. These equations define the configuration of the chain in terms of its joint parameters. Forward kinematics uses the joint parameters to compute the configuration of the chain,
and inverse kinematics reverses this calculation to determine the joint parameters that achieves a desired configuration.

For example, inverse kinematics formulas allow calculation of the joint parameters that position a robot arm to pick up a part. Similar formulas determine the positions of the skeleton of an animated character that is to move in a particular way.
Skeleton of a cat:

Carnivorous mammal of the feline family, with retractile claws. There are both wild and domestic varieties.

**Skull**: Bony case of the brain.

Cervical vertebrae: Bones of the neck.

**Thoracic vertebrae**: The bones forming the dorsal part of the thoracic cage.

**Lumbar vertebrae**: The bones of the lumbar region of the back.

**Sacrum**: The set of sacral vertebrae.

**Caudal vertebrae**: Bones of the tail.

**Pelvis**: Pelvic bone.

**Femur**: Uppermost bone of the rear leg of a cat.

**Fibula**: One of two bones of the lower rear leg of a cat.

**Tarsus**: Hell bone.

**Metatarsus**: Paw bone between the heel and the phalanges.

**Phalange**: Toe bone.

**Claw**: Pointed nail at the end of a phalange.

**Tibia**: One of two bones of the lower rear leg of a cat.

**Rib**: Bone of the thoracic cage.

**Ulna**: One of two bones of the lower foreleg of a cat.

**Nail**: Pointed nail at the end of a phalange.

**Radius**: One of two bones of the lower foreleg of a cat.

**Humerus**: Bone of the upper foreleg of a cat.

**Sternum**: Bone forming the underside of the thoracic cage.

**Scapula**: Shoulder bone.

**Mandible**: Lower jaw.

**Tooth**: Hard organ set in the jaw, used to chew food.

**Orbit**: Cavity in the skull that contains the eye.
Anatomy (learn the following topics with teacher’s assistance)

**Quadruped Anatomy**
- Review the basic structure of a typical quadruped skeleton. Quadruped Skeleton

**Human Anatomical Variation**
- Illustrate and distinguish the major differences among male, female, old and young, quadruped and creature anatomy.

**Natural Biped Joint Rotation**
- Review the natural joint rotation limits (articulation) and root of motion (hips) of the biped anatomy.

**Natural Quadruped Joint Rotation**
- Review the natural rotation limits (the articulation) and root of motion (hips and shoulders) of a typical quadruped anatomy.

**Skin Deformation**
- Review how muscles deform skin and change the appearance of a character’s body.

---

**Summary**

A typical 3D character can be made up of many surfaces and components. To ensure that the character animates in the way that you want, it is important to carefully plan the process of character setup. Character setup or rigging is the general term used for the preparation of 3D models with their accompanying joints and skeletons for animation.

Depending on the model to be animated, character setup can involve the following techniques:

- Creating a skeleton with joints that acts as a framework for the 3D character model. You set limits on the joints so they rotate in a convincing manner. When you animate the character, you position the character’s joints using either forward or inverse kinematic techniques (FK or IK).

- Binding the 3D surfaces to the skeleton so that they move together. The process of binding may also include defining how the character’s joints bend or how the skin surfaces bulge to simulate muscles.

- Defining and setting constraints for particular animated attributes in order to restrict the range of motion or to control an attribute based on the movement of another.
• Grouping surface components such as CVs into sets called clusters so that parts of the character can be animated at a more detailed level.

**Short Answer Type Questions**

1. What is the use of skeleton in rigging?
2. What is skinning?
3. What are parent child joints in rigging? (General)
4. Define Inverse kinematics.
5. Define forward kinematics.

**Long Answer Type Questions**

1. What is character rigging; explain in detail with proper examples.
2. Write about IK and FK in detail with proper examples.
3. Why Anatomy knowledge is so much important in character setup, elucidate.
4. List important Anatomies.
5. Write about Human anatomy, in general, in Animation perspective.
Learning Objectives

In this unit, the student will learn about what is and how animation is created for various industries, and technology aspects of its creation, will be discussed in detail.

What is Animation?

Animation is a type of optical illusion; it is the process by which we see still pictures move. It involves the appearance of motion caused by displaying still images one after another at the rate of 24 pictures per second. The most common method of presenting animation is as a motion picture or video program, although several other forms of presenting animation also exist.

Autodesk Maya supports various animation techniques i.e.

- Key frame,
- Motion Path,
- Expression,
- Simulation,
- Motion Capture, etc.

Instructor discusses their common applications and benefits with the students.

Another important in animation is Motion Dynamics; it consists of two sub topics. They are 1. Frame Rate, 2. Persistence of Vision.
Frame rate

Frame rate (also known as frame frequency) is the frequency (rate) at which an imaging device produces unique consecutive images called frames. The term applies equally well to film and video cameras, computer graphics, and motion capture systems. Frame rate is most often expressed in frames per second (FPS) and is also expressed in progressive scan monitors as hertz (Hz).

Persistence of vision

Persistence of vision is the phenomenon of the eye by which an afterimage is thought to persist for approximately one twenty-fifth of a second on the retina.

The myth of persistence of vision is the belief that human perception of motion (brain centered) is the result of persistence of vision (eye centered). The myth was debunked in 1912 by Wertheimer but persists in many citations in many classic and modern film-theory texts. A more plausible theory to explain motion perception (at least on a descriptive level) are two distinct perceptual illusions: phi phenomenon and beta movement.

A visual form of memory known as iconic memory has been described as the cause of this phenomenon. Although psychologists and physiologists have rejected the relevance of this theory to film viewership, film academics and theorists generally have not. Some scientists nowadays consider the entire theory a myth.

In contrasting persistence of vision theory with phi phenomena, a critical part of understanding that emerges with these visual perception phenomena is that the eye is not a camera. In other words vision is not as simple as light registering on a medium, since the brain has to make sense of the visual data the eye provides and construct a coherent picture of reality. Joseph Anderson and Barbara Fisher argue that the phi phenomena privileges a more constructionist approach to the cinema (David Bordwell, Noël Carroll, Kirsten Thompson), whereas the persistence of vision privileges a realist approach (André Bazin, Christian Metz, Jean-Louis Baudry).

The discovery of persistence of vision is attributed to the Roman poet Lucretius, although he only mentions it in connection with images seen in a dream. In the modern era, some stroboscopic experiments performed by Peter Mark Roget in 1824 were also cited as the basis for the theory.

Animation Techniques:

Computer Animation in general follows the below given techniques

- Key frame
Key frame

A key frame in animation and filmmaking is a drawing that defines the starting and ending points of any smooth transition. The drawings are called “frames” because their position in time is measured in frames on a strip of film. A sequence of key frames defines which movement the viewer will see, whereas the position of the key frames on the film, video or animation defines the timing of the movement. Because only two or three key frames over the span of a second do not create the illusion of movement, the remaining frames are filled with in-betweens.

In-between

Inbetweening or tweening is the process of generating intermediate frames between two images to give the appearance that the first image evolves smoothly into the second image. In-betweens are the drawings between the key frames which help to create the illusion of motion. Inbetweening is a key process in all types of animation, including computer animation.

Interpolation (In connection with linear, constant, stepped, spline)

In computer programming, variable interpolation (also variable substitution or variable expansion) is the process of evaluating an expression or string literal containing one or more variables, yielding a result in which the variables are replaced with their corresponding values in memory. It is a specialized instance of concatenation. Languages that support variable interpolation includes Perl, PHP, Ruby, Tcl, Groovy, and most UNIX shells. In these languages, variable interpolation only occurs when the string literal is double-quoted, but not when it is single-quoted. The variables are recognized because variables start with a sigil (typically “$”) in these languages. For example, the following Perl code (which would work identically in PHP).

Newton’s Laws of Motion:

- Inertia
- Acceleration
- Force
- Mass
- Action and Reaction
Inertia

Newton’s laws of motion are three physical laws that form the basis for classical mechanics. They describe the relationship between the forces acting on a body and its motion due to those forces. They have been expressed in several different ways over nearly three centuries, and can be summarized as follows:

- **First law**: If there is no net force on an object, then its velocity is constant. The object is either at rest (if its velocity is equal to zero), or it moves with constant speed in a single direction.

- **Second law**: The acceleration $a$ of a body is parallel and directly proportional to the net force $F$ acting on the body, is in the direction of the net force, and is inversely proportional to the mass $m$ of the body, i.e., $F = ma$.

- **Third law**: When a first body exerts a force $F_1$ on a second body, the second body simultaneously exerts a force $F_2 = -F_1$ on the first body. This means that $F_1$ and $F_2$ are equal in magnitude and opposite in direction.

The three laws of motion were first compiled by Sir Isaac Newton in his work *Philosophiæ Naturalis Principia Mathematica*, first published in 1687. Newton used them to explain and investigate the motion of many physical objects and systems. For example, in the third volume of the text, Newton showed that these laws of motion, combined with his law of universal gravitation, explained Kepler’s laws of planetary motion.

Acceleration

In physics, acceleration is the rate at which the velocity of a body changes with time. In general, velocity and acceleration are vector quantities, with magnitude and direction, though in many cases only magnitude is considered (sometimes with negative values for deceleration, treating it as a one dimensional vector). Acceleration is accompanied by a force, as described by Newton’s Second Law; the force, as a vector, is the product of the mass of the object being accelerated and the acceleration (vector). The SI unit of acceleration is the meter per second squared (m/s²).

For example, an object such as a car that starts from standstill, then travels in a straight line at increasing speed, is accelerating in the direction of travel. If the car changes direction at constant speedometer reading, there is strictly speaking an acceleration although it is often not so described; passengers in the car will experience a force pushing them back into their seats in linear acceleration, and a sideways force on changing direction. If the speed of the car decreases, it is usual and meaningful to speak of deceleration; mathematically it is acceleration in the opposite direction to that of motion.
Force

In physics, a force is any influence that causes an object to undergo a certain change, either concerning its movement, direction, or geometrical construction. It is measured in the SI unit of newtons and represented by the symbol F. In other words, a force can cause an object with mass to change its velocity (which includes to begin moving from a state of rest), i.e., to accelerate, or a flexible object to deform, or both. Force can also be described by intuitive concepts such as a push or a pull. A force has both magnitude and direction, making it a vector quantity.

The original form of Newton’s second law states that the net force acting upon an object is equal to the rate at which its momentum changes with time. If the mass of the object is constant, this law implies that the acceleration of an object is directly proportional to the net force acting on the object, is in the direction of the net force, and is inversely proportional to the mass of the object.

Related concepts to force include: thrust, which increases the velocity of an object; drag, which decreases the velocity of an object; and torque which produces changes in rotational speed of an object. In an extended body, each part usually applies forces on the adjacent parts; the distribution of such forces through the body is the so-called mechanical stress. Pressure is a simple type of stress. Stress usually causes deformation of solid materials, or flow in fluids.

Mass

In physics, mass refers to the quantity of matter in an object. More specifically, inertial mass is a quantitative measure of an object’s resistance to acceleration. In addition to this, gravitational mass is a quantitative measure that is proportional to the magnitude of the gravitational force which is

- Exerted by an object (active gravitational mass), or
- Experienced by an object (passive gravitational force)

When interacting with a second object. The SI unit of mass is the kilogram (kg).

Action and Reaction

The third of Newton’s laws of motion of classical mechanics states that forces always occur in pairs. This is related to the fact that a force results from the interaction of two objects. Every force (‘action’) on one object is accompanied by a ‘reaction’ on another, of equal magnitude but opposite direction. The attribution of which of the two forces is action or reaction is arbitrary. Each of the two forces can be considered the action, the other force is its associated reaction.

Friction is another important topic under Motion Dynamics.
What is Friction: Friction is the force resisting the relative motion of solid surfaces, fluid layers, and material elements sliding against each other. There are several types of friction:

- Dry friction resists relative lateral motion of two solid surfaces in contact. Dry friction is subdivided into static friction (“stiction”) between non-moving surfaces, and kinetic friction between moving surfaces.

- Fluid friction describes the friction between layers within a viscous fluid that are moving relative to each other.

- Lubricated friction is a case of fluid friction where a fluid separates two solid surfaces.

- Skin friction is a component of drag, the force resisting the motion of a solid body through a fluid.

- Internal friction is the force resisting motion between the elements making up a solid material while it undergoes deformation.

When surfaces in contact move relative to each other, the friction between the two surfaces converts kinetic energy into heat. This property can have dramatic consequences, as illustrated by the use of friction created by rubbing pieces of wood together to start a fire. Kinetic energy is converted to heat whenever motion with friction occurs, for example when a viscous fluid is stirred. Another important consequence of many types of friction can be wear, which may lead to performance degradation and/or damage to components. Friction is a component of the science of tribology. Friction is not itself a fundamental force but arises from fundamental electromagnetic forces between the charged particles constituting the two contacting surfaces. The complexity of these interactions makes the calculation of friction from first principles impossible and necessitates the use of empirical methods for analysis and the development of theory.

Animation Technique Breakdown

How it happens, in general persistence of vision occurs when some change happens over time. Based on this simple principles we can animate objects in general like moving from one position to other, changing colors, opacity etc.

But, most people have a fear of animating walk cycles. Many events are happening at the same time, and it can seem overwhelming. A single mistake on your first drawing can wreck the rest of the scene. However, the process can be broken down into a series of steps which can go some distance in simplifying the process.

A walk cycle can be described by four distinct poses

1. Contact,
2. Recoil,
3. Passing and
4. High-Point.
These four poses and a couple of in-between drawings constitute a walk cycle. The single most important frame of the four is the contact pose. Once you draw it you have already determined 80% of the rest of your walk. If you make a mistake on your contact pose, it can be very difficult to correct later on. Therefore: pay close attention now and save yourself a world of pain.

Many of the principles of traditional animation were developed in the 1930’s at the Walt Disney studios. These principles were developed to make animation, especially character animation, more realistic and entertaining. These principles can and should be applied to 3D computer animation.

Principles of Traditional Animation (instructor shows various examples on each principle)

The following principles were developed and named

1. **Squash and Stretch**: Defining the rigidity and mass of an object by distorting its shape during an action

2. **Timing and Motion**: Spacing actions to define the weight and size of objects and the personality of characters

3. **Anticipation**: The preparation for an action

4. **Staging**: Presenting an idea so that it is unmistakably clear

5. **Follow Through and Overlapping Action**: The termination of an action and establishing its relationship to the next action

6. **Straight Ahead Action and Pose-to-Pose Action**: The two contrasting approaches to the creation of movement

7. **Slow In and Out**: The spacing of the in-between frames to achieve subtlety of timing and movement

8. **Arches**: The visual path of action for natural movement

9. **Exaggeration**:Accentuating the essence of an idea via the design and the action

10. **Secondary Action**: The action of an object resulting from another action

11. **Appeal**: Creating a design or an action that the audience enjoys watching

12. **Personality**: In character animation is the goal of all of the above.
A little knowledge of the following topics may improve animation quality in general.

**Euler vs. Quaternion’s**

The Euler angles are three angles introduced by Leonhard Euler to describe the orientation of a rigid body. To describe such an orientation in 3-dimensional Euclidean space three parameters are required. They can be given in several ways, Euler angles being one of them; see charts on SO(3) for others. Euler angles are also used to represent the orientation of a frame of reference (typically, a coordinate system or basis) relative to another.

Unit quaternions, also known as versors, provide a convenient mathematical notation for representing orientations and rotations of objects in three dimensions. Compared to Euler angles they are simpler to compose and avoid the problem of gimbal lock. Compared to rotation matrices they are more numerically stable and may be more efficient. Quaternion’s have found their way into applications in computer graphics, computer vision, robotics, navigation, molecular dynamics, flight dynamics, and orbital mechanics of satellites.

When used to represent rotation, unit quaternions are also called rotation quaternions. When used to represent an orientation (rotation relative to a reference position), they are called orientation quaternions or attitude quaternions.

**Summary**

Maya lets you apply action to the objects in your 3D scene. In Maya, when an object or attribute changes in relation to time, it is referred to as being animated. Maya provides a large selection of tools to help you animate the objects in your scene. You may decide to use a combination of several techniques to achieve your desired results.

In this chapter, you learned some common techniques and features that highlight Maya’s computer animation technology: Key frames and the Graph Editor: Set Driven Key; Path animation; Nonlinear animation with Trax; Inverse kinematics.

**Short Answer Type Questions**

2. Difference between Key frame and In between animation.
3. Write about your favorite animation character(s) (in General).
4. What is the difference between 2d / 3d Animation?
5. List important animation techniques in Maya.

**Long Answer Type Questions**

1. Define Animation and write about types of animation.

2. What is persistence of vision?

3. What is Key frame Animation?

4. Write about Principles of Animation.

5. Write about walk cycle in detail.
Learning Objectives

In this unit the student will study various properties of the matter, in order to create stunning visual FX or Dynamic effects for film, television and gaming content. Once when student understands the states of the matter and its dynamics in depth, then he/she will be ready for working of stunning VFX/Effects/Dynamics projects.

What are Dynamics / Effects in Maya?

Dynamics is a branch of physics that describes how objects move using physical rules to simulate the natural forces that act upon them. Dynamic simulations are difficult to achieve with traditional key frame animation techniques. Maya provides a means to do this type of computer animation where you set up the conditions that you want to occur, then let the software solve how to animate the objects in the scene. Maya® Dynamics™ provides the tools for creating effects that will enhance your final images and animations. With Particle Effects, you can create the illusions of smoke, fireworks, rain, fire, and explosions.

With Rigid Body Dynamics, you can simulate real-world physical interactions between objects, such as collisions between surfaces. For example, you can simulate a bowling ball crashing through pins or simulate the effects of gravity when a ball falls to the ground. You can also simulate natural forces, such as wind.

Following points will give you a clear understanding of Dynamics basics.
Analytical Dynamics

States of Matter

States of matter in physics are the distinct forms that different phases of matter take on. Four states of matter are observable in everyday life: solid, liquid, gas, and plasma. Many other states are known such as Bose–Einstein condensates and neutron-degenerate matter but these only occur in extreme situations such as ultra cold or ultra dense matter. Other states, such as quark-gluon plasmas, are believed to be possible but remain theoretical for now. For a complete list of all exotic states of matter, see the list of states of matter.

Historically, the distinction is made based on qualitative differences in properties. Matter in the solid state maintains a fixed volume and shape, with component particles (atoms, molecules or ions) close together and fixed in place. Matter in the liquid state maintains a fixed volume, but has a variable shape that adapts to fit its container. Its particles are still close together but move freely. Matter in the gaseous state has both variable volume and shape, adapting both to fit its container. Its particles are neither close together nor fixed in place. Matter in the plasma state has variable volume and shape, but as well as neutral atoms, it contains a significant number of ions and electrons, both of which can move around freely. Plasma is the most common form of visible matter in the universe.

Newton’s Laws of Motion

Newton’s laws of motion are three physical laws that form the basis for classical mechanics. They describe the relationship between the forces acting on a body and its motion due to those forces. They have been expressed in several different ways over nearly three centuries, and can be summarized as follows:

**First law:** If there is no net force on an object, then its velocity is constant. The object is either at rest (if its velocity is equal to zero), or it moves with constant speed in a single direction. **Second law:** The acceleration $a$ of a body is parallel and directly proportional to the net force $F$ acting on the body, is in the direction of the net force, and is inversely proportional to the mass $m$ of the body, i.e., $F = ma$. **Third law:** When a first body exerts a force $F_1$ on a second body, the second body simultaneously exerts a force $F_2 = -F_1$ on the first body. This means that $F_1$ and $F_2$ are equal in magnitude and opposite in direction.

The three laws of motion were first compiled by Sir Isaac Newton in his work *Philosophiæ Naturalis Principia Mathematica*, first published in
Newton used them to explain and investigate the motion of many physical objects and systems. For example, in the third volume of the text, Newton showed that these laws of motion, combined with his law of universal gravitation, explained Kepler’s laws of planetary motion.

**Physical Properties**

A physical property is any property that is measurable whose value describes a state of a physical system. The changes in the physical properties of a system can be used to describe its transformations or evolutions between its momentary states. Physical properties are often referred to as observables. They are not modal properties.

Physical properties are often characterized as intensive and extensive properties. An intensive property does not depend on the size or extent of the system, nor on the amount of matter in the object, while an extensive property shows an additive relationship. These classifications are in general only valid in cases when smaller subdivisions of the sample do not interact in some physical or chemical process when combined.

Properties may also be classified with respect to the directionality of their nature. For example, isotropic properties do not change with the direction of observation, and anisotropic properties do have spatial variance.

It may be difficult to determine whether a given property is a material property or not. Color, for example, can be seen and measured; however, what one perceives as color is really an interpretation of the reflective properties of a surface and the light used to illuminate it. In this sense, many ostensibly physical properties are called supervenient. A supervenient property is one which is actual, but is secondary to some underlying reality. This is similar to the way in which objects are supervenient on atomic structure. A cup might have the physical properties of mass, shape, color, temperature, etc., but these properties are supervenient on the underlying atomic structure, which may in turn be supervenient on an underlying quantum structure. Physical properties are contrasted with chemical properties which determine the way a material behaves in a chemical reaction.

**Physical Forces**

In physics, a force is any influence that causes an object to undergo a certain change, either concerning its movement, direction, or geometrical construction. It is measured in the SI unit of newtons and represented by the symbol F. In other words, a force can cause an object with mass to change its velocity (which includes to begin moving from a state of rest), i.e., to accelerate,
or a flexible object to deform, or both. Force can also be described by intuitive concepts such as a push or a pull. A force has both magnitude and direction, making it a vector quantity.

The original form of Newton’s second law states that the net force acting upon an object is equal to the rate at which its momentum changes with time. If the mass of the object is constant, this law implies that the acceleration of an object is directly proportional to the net force acting on the object, is in the direction of the net force, and is inversely proportional to the mass of the object. As a formula, this is expressed as:

\[ \vec{F} = m\vec{a} \]

where the arrows imply a vector quantity possessing both magnitude and direction.

Related concepts to force include: thrust, which increases the velocity of an object; drag, which decreases the velocity of an object; and torque which produces changes in rotational speed of an object. In an extended body, each part usually applies forces on the adjacent parts; the distribution of such forces through the body is the so-called mechanical stress. Pressure is a simple type of stress. Stress usually causes deformation of solid materials, or flow in fluids.

**Naturally Occurring Phenomena**

Study all Naturally Occurring Phenomena like Rock Slides, Earthquakes, River flow, Waterfalls, Avalanches, Ocean Waves, Fire, Lightning, Tornado, Explosion, Dust Storm, Rain etc. (Video clips and Still Pictures)

**Short Answer Type Questions**

1. Dynamics is a branch of physics, elucidate.
2. What is Rigid Body Dynamics?
3. Briefly explain Newton’s Laws of Motion
4. Explain at least 3 important Naturally Occurring Phenomena

**Long Answer Type Questions**

1. How can we create the illusions of smoke, fireworks, rain, fire, and explosions in Autodesk Maya.